Cant Update Firmware?

Downloaded the file from the thread for the new October firmware and put it onto my SD card just like the last update. When i plug the card into the unit it doesnt update it or search for the new firmware it just loads up like normal… Any help?

Have you tried doing this in MSC mode directly from the S2400?

No truthfully i never set it up in that mode before, when I first got it I tried and I couldn’t get it to work.

That is odd. That should definitely work. What OS and system are you on? Can you try to connect it with a different computer to see if that will connect?

The only other suggestion is try try a different SD card.

i saw in another thread they said to change the file name to upf instead of upd and i just tried that and now my unit wont even turn on. This is bullshit… Why cant this stuff just work easy like cmon.

will your unit turn on without the card? If so put the card back into the computer and reformat the card and put the previous firmware on the card and see if it boots up.

It will not turn on at all now, with or without card. I would try to reformat the card however if i do that and it still doesnt work then im just even more out of luck losing everything ive done so far on the card lol.

Okay then in your shoes I might remove any cables, then check the power connection just to be sure (it’s not likely to work but sometimes electronics act like there is a ghost in the machine and do something strange like just start working again) and then send a ticket if still won’t turn on.

I tried all that and got nothing. I was so hype for the 2400 man, I really was but so far its been nothing but a disaster nothing works it is so damn frustrating. The thing that makes this unit so dope is that it has all that oldschool charm and sound to it with a modern workflow but when nothing works it doesnt really mean much you know? My old mpcs always work like a charm. I know I sound bitter but like I havent even owned this for much longer than a month maybe and it already wont turn on…? This is depressing =/

It happens, put in a ticket. I had an issue with mine and had to send it in. It’s possible Rob can help you trouble shoot the problem before it comes to that.

1 Like

alright thanks i really do appreciate the help and replies. Lets hope I dont have to send it in.

how do i put in a ticket lol


Ok thanks.

They didn’t respond to my ticket yet but i just fixed it! Figured I’d let it be known lol. Im stoked

What was the fix?

I browsed around the forum so I tried a few things but what seemed to work for me was first I unscrewed the side and moved the wires for the power down towards the bottom of the unit away from the ribbon cable. At this point it was still not turning on and stuck blank screen so I cleared my SD card by reformatting it and then loaded the last (August) firmware on it and tried to load that onto the unit. This didn’t work so I took that off the and then changed the file name and loaded the August firmware onto my SD card as .upf file. This got my unit on again as it only took maybe like 5-10 seconds to boot up with the august firmware on it. Then I tried the new firmware normally again like I initially tried to do but it didnt work again so I tried .upf again with the new firmware file and in maybe 30 seconds it booted up all good to go with new October firmware. writing in detail so that hopefully somebody in the future can find this post and maybe it helps them lol. As to why it worked this time vs last time I have no clue lol, maybe the moving of cables but it didnt look like they were really touching the ribbon cable but idk. Anyway it seems fine now and before I reformated the card I copied the whole folder to my desktop so im gonna try to drag it back over now and hopefully all my projects and files load like nothing happened.

1 Like

Thanks that is exactly what I was hoping for. This assists us and others who might have a similar issue.

1 Like

I responded to your ticket on Saturday, what do you mean?

Here is my response:

1 Like

Sorry this was my first time creating a ticket it said when I submitted it that I would get a response to my email I never got an email so I thought I didn’t get a response. I’m still new to this whole thing. Sorry I wasn’t trying to slander the support team or anything. Thanks for the initial response funny enough that’s what I did I saw it suggested in another thread. Thanks again

1 Like