Help with firmware update

Ive downloaded the latest update to my laptop and my sd card, which has some samples on it too. When I go into MSC mode, I see the file on the computer, and I see it on the SD card. Nothing happens. I double click the file on the pc, which comes up in MSC mode, but nothing happens. I press Back on the 2400, and goes into normal turned on state. Firmware still says july version. Ive also done the Root save with ctrl c and ctrl v, into the SD card. Do I need to do the emergency update with changing the .upd into .upf as stated at the start of the firmware update category Brad made?
I would be pleased to get any help with this. Thank you.

Try just ejecting the card and reinserting it

nothing happens. when i go into msc mode, it say the sd card can now be accessed from a computer, press back to exit.

Once the upd file is copied to the SD card, there is no reason to go back to MSC mode for updating.

i see the file on the sd card, on the pc screen, but its not copying
firmware still says july version. not sure what im missing?

When the S2400 sees the upd file on the SD card, it will ask if you want to perform the update.

If the upd file is not seen when you exit MSC mode, it may be seen when you eject and reinsert the SD card.

Or, it may be seen when you reboot the machine. In that case, the screen will be blank for about 2 minutes while it does the update.

If the upd file is still not seen, try renaming the extension to upf, and try the above steps again.

not once has it asked me if i want to perorm the update. it just says sd card can be accessed from a computer. on the computer screen, i see the file, and the samples i put on the card. when i dbl click the update file nothing happnes. i think i will try changing it to UPF and doing the cold start with it inserted already.
thanx will let you know what happens

Double clicking the update file on your computer does nothing. Your computer has no idea what that file is. Only the S2400 recognizes it as a firmware update.

good to know. can it be a firewall issue? or some kind of security blocking communication? a bad download file? erase and copy all over maybe? ill start with the upf first. thanx again Mickey. ill let u know in a few minutes

well i changed it to upf and inserted while off, turned on, nothing happened, went into msc mode, same msg apppears. no prompts on laptop for update. i will try same procedure using my home computer instead to see if theres some weird thing stopping it? or this that just silly?

If the file is on the SD card, then there is nothing else your computer is needed for.
If the S2400 is still not seeing the file on the SD card. Please put in a support ticket, and they will get you going.

will do and thank you for trying to help. hopefully we will get it figured out. in the meantime ill make do with this version. cheers.

1 Like

Go here to open a support ticket:

well it worked when i erased it and copied it again from my home computer! I did everything the exact same way, only this time, when I turned on the 2400, i waited and put the card in after a few seconds, and it read it and updated! Great news. I already made a ticket. I will update it right now so nobody wastes anymore time on this. Take care and thank you. Have a great day.

1 Like

Someone else had a problem when trying to do an update from a work laptop. Security blocks files from being saved properly onto SD drives.

Do not use work issued laptops for updates.

yah! I figured that out too. thank you once again. sorry for being such a noob and bothering you guys.