Firmware update tutorial video

Is there a video Or step by step guide someone can link me to?

I have tried using the S2400 as a drive with a PC, but have been unable to copy the file to the drive.
Im sure it’s a very simple procedure, but I do not own a computer myself & can be ignorant of some of the most basic functions
Thank you

I apologize in advance if this post is not in the right spot

1 Like

Hey @Joseph The steps are

  1. Connect the S2400 to your Mac/PC
  2. Hit Shift + File on the S2400 and enable USB MSC mode
  3. Wait for the S2400 to appear on the computer as an external drive
  4. Copy updates to the root of the SD card directory
  5. (Optional) Eject the S2400
  6. Exit USB MSC Mode on the S2400

At that point you should see an update prompt on the 2400. If you do not, cycle power on the 2400 and you will see it then.

If something isnt working for one of these steps post back and we can work from there.


Thanks for the reply!
I’ve made it to step 4.

I have the file copied to the desktop of the PC & I open the S2400 (in MSC mode) as “drive d” on the desktop.
Then if I click in the file, the drive disappears.
If I right click the file & try to “send to” there is no option for the drive.
I just can’t copy it to the drive.

Definitely seems like I’m not doing something very simple.

Not sure if I need to connect the s2400 differently or maybe I need to do something differently with the file.

Thanks for the help

Ok- so if Im reading correctly the S2400 disappears when you try to copy the file over? I would start by trying a few things- Try a new USB cable, new SD card in the S2400(start with USB cable, then if it still isnt working try a different SD card) Also make sure the SD card is formatted by the 2400 and not encryoted or set to write protect(If I remember correctly some cards have a little switch on them that can prevent that)

If the drive disappears, does the D/S2400 drive show back up or once you try to copy it disappears and you have to reattach to the 2400?

@StupidAmericanPig is an OG, his instructions are dead on but have you tried dragging and dropping the file? I’ve done FW updates on both Mac and PC - I find that on PC, opening two separate file windows, one with your downloads and one with the S2400 drive, then dragging the FW update straight from your downloads to the root (area with project folders) of the S2400 drive/SD card. I can’t think of a reason your PC would know to eject the drive by just clicking the FW file…they don’t communicate until you physically move it - unless that’s what’s happening. Try drag and drop and see if the drive still ejects itself.

FYI though in case you didn’t know, there’s an official video tutorial/manual series that covers all the basics and then some. Alex Ball put together for the Isla YouTube channel - the latest installment being Firmware updating, tips and tricks. Check out the rest of the series too, I find myself re-watching them all the time they’re super in depth and Alex just has a way with tutorials.

1 Like

Thanks for your response!
I don’t think it’s the card or cable, but I’ll try both those suggestions regardless.

The drive does stay somewhere on the computer once it disappears, but it’s easiest for me to find by reconnecting the s2400. I can open the drive & see the folders & content of the “drive”/S2400.

Thanks for your help & I’ll try those trouble shooting suggestions tonight when I get a few more minutes with the PC again.

Thank you for your time!

I tried to drag & drop it on the drive like you’re suggesting (with two windows open) & I also tried moving the file to the desktop and then dragging & dropping it on the drive.
The drive disappears.
Those tutorials are amazingly informative—Alex Ball is a proper musician & explains the tech info of the S2400 very well, but I haven’t seen any video of the the computer side of the updating of the firmware & to be fair—this feels like it has more to do with my ignorance of a PC’s OS than the S2400.

I’ll try with a new cable tonight.

Thanks for your response

Have you ever used or owned a multicard reader?

There is this option too. Put your SD card in the card reader. Plug the card reader to the PC. Drag and drop the firmware file at the root of the SD card. Remove the card reader from the PC. Remove the SD card from the card reader. Put the SD card back in the S2400. Update the firmware.

1 Like

@Joseph as @tnkz76 suggested there are a bunch of ways we can tackle this, so please do report back if you are still having issues. We will just have to eliminate the variables one by one until it works.

Thanks for the response

That makes sense & If I’m unable to make the s2400 work as a drive, an SD card reader is definitely my next option.

thanks for the help.

1 Like

I had an issue initially with terrible connectivity with my S2400 to my mac. I also tried it on the PC and the same thing would happen. For me the S2400 would just disconnect. In my case my SD card was bonkered it was a counterfeit San Disk. About 1/3rd of the cards you can buy on the internet are counterfeit and in my case mine went bad stat. So I had to buy another one. Do you have another SD card handy that you could try instead? Have you tried reformatting the card you do have?

This really should be an easy process on either a mac or pc. It’s truly a drag and drop situation unless the connectivity is a problem. But the fact it’s behaving erratically as soon as you try to put something on the card via the External HD makes me think it’s not a cable.

1 Like

This could well be a Windows 10 problem. Reinstall the drivers for \drive D by going to device manager and update driver. If that doesnt work tr renaming Drive D to another letter. This.

Apart from updating device drivers in Windows 10, you can also change the drive letter of the disappeared hard drive to solve the problem. Follow the steps to change the drive letter of the disappeared hard drive;

  1. In the first step, you need to press the “Windows + R” keys, which will bring up the Run dialog.

  2. In the next step, you are required to type “diskmgmt.msc” and press enter to open the disk management.

  3. Once it is open, the disappeared hard drive will be detected now, and you can right-click on it and choose the option “Change drive letters and paths.”

Disappearing drives are not uncommon.

Thanks for the responses & help.
After troubleshooting, I am confident that the issue is with the computer, but not only is the computer not mine, but it’s also used for work & I can’t modify it with drivers, etc—I don’t have full access to the device manager even if I wanted to tinker with it.

Thanks for all the help, but I will have to find another more obedient computer to complete the firmware update properly—shouldn’t be too difficult.

Thanks again & I appreciate all of the responses

1 Like

It might well have managed security policies in place that prohibit you from transferring files onto removable disks (stealing company info) It’s a pointless security policy (hello internet uploads) but sometimes put in place nonetheless.

Yup. If you cant even get to the device manager then you have to be the Administrator to get into it to make any changes.

1 Like

Ahh yep that’ll do it - I tried using my company machine a while back to grab some of @StupidAmericanPig Dusty Drums, and promptly received a call from my tech team asking WTH I doing. As @bradholland said, dragging and dropping files to an unknown external drive on a corporate machine looks like “stealing company info” from an insider threat perspective. Your org may likely have ITM or SIEM software to mitigate, but clearly at least managed security that auto-ejects external drives upon file transfer.

If you don’t have easy access to another machine it can’t hurt to ask your org for permission, worst they’ll say is no - mine gave me the green light once I explained what it was.

Either way, glad you narrowed down the issue and happy FW updating!

1 Like

Thanks for the replies

I have now procured the usage of an acceptable computer & using a card reader, I’ve copied the file to the SD card.
I’ve put the SD card back in the S2400 & turn it on & it just has the old firmware.

My question is: do I need to rename the file on the SD card to make it a “forced” update? Or is there something else that I should try first that I’m missing?

Thank you for the help

The .upd file will be recognized by the 2400 and automagically prompt for update.

Edit- if the machine is not seeing the firmware update, pop out the SD card and put it back in.

After turning the unit on, have you tried to pop the SD card out and back in?

Was the firmware file copied at the root of the SD card.

You should not need to rename and do a forced update.

Thanks—That did it
I knew I was missing something simple

Thanks to all who responded
Mission accomplished