Latest Update not working? PLEASE HELP

Hi All,

I have copy the file into the card via USB MSC the file can be seen on the card while looking from the machine. the file is marked with a question mark and will not update.

Please if anyone has any idea about this?

Thank you!

Can you confirm which file you’re copying across? It should be S2400_20220224_082026.upd

If it helps, I couldn’t get my 2400 to update via MSC for this last update. However, once I popped the sd card out, loaded the bin file directly, and then popped it back into the s2400 and fired up it work for me. Maybe try without MSC mode

Follow the instructions on this thread: Frozen screen firmware update - #3 by roborr and your machine will be back up and running once you have done so.

had the exact same behavior. Exiting MSC nothing happens and file has a question mark next to it when browsing. Machine isn’t stuck or anything it just exits msc and doesn’t start the update. did the forced update : Renamed the file extension to upf, exited msc, ejected card, powered down, inserted card, powered up. Machine started w blank screen a for few minutes and then eventually display lit up with current firmware version showing. .

hi guys,

trying to update using the forced update process (as it worked fine last time). changed file to .upf on my mac, dropped it onto sd card, put the sd card back in the s2400, switched on, blank screen, blank screen, blank screen…HELP!

ah, ok, it’s sorted now.
left it trying for ages (30mins) then gave up, and switched off. went for a cigarette, checked the file was ok again in my mac, and tried again. it worked.

who said smoking was a bad thing?! :face_with_spiral_eyes: