Update not found after exiting MSC mode, but found workaround

I tried several things to get todays update to load with no luck at first. The update file was on the root of the card as perscribed. I tried to rename the file format UPF, which also didnt work. I changed it back to UPD and restarted the S2400 and it didnt work. However, I popped out and reinserted the SD card and it immediately went into update mode. If any folks are noticing that they cant get the update to start, may be worth trying that…


Yep, had the same issue, and your method of popping it, in/out is working! cheers


I’ve tried copying it to root in MSC mode and direct to my computer, both times didn’t recognize the update file. Are you hot swapping the card or just rebooting and popping the card out in between?

@mleitzell yep that is what was happening with me. Making sure the file is in the root of the SD card, turn off the S2400, turn it back on. As soon as the faders show up, pop the sd card out(just push in to release it is all I did) Then push it back in and it should see the update.

Worked great, thanks.

1 Like

Did same, popped card in and out, recognized the update and went through fine.

Also had this happen to me except my unit went completely dark and wouldn’t turn on. I scrolled up on the update thread where @bradholland states that this may happen and just let it sit. I let it sit and sure enough 2-3 mins later it was back up and running (working fine now)!

1 Like

Thanks for this tip! It worked for me. PC user

1 Like

Can confirm, had the same issue and that worked

Had the same but came across the same suggestion to eject/insert SD card in Brad’s post about applying the update. It worked.

Did the same for me. Thanks

Update - when I did the bug patch for the new FW using MSC mode, as soon as I exited MSC mode it prompted the update immediately. Maybe it was a bug that was caught?

Also, not sure it makes any difference (guessing not), but I’m on a Mac and I made sure to “properly eject the drive” (S2400) this time as previous times I just hit exit on the 2400 and then Mac would say “drive not ejected properly” or something. I don’t think it has anything to do with it, but FWIW