Pad sensitivity issue after July firmware

Strangest thing, after installing the July firmware my pads started having a very weird sensitivity issue. If hitting them with a normal to heavier amount of pressure they only seem to trigger about 30-40% of the time. If I very lightly depress the pads they seem to work most of the time. I tried changing the threshold from 0 to 99 and everywhere in between and nothing seemed to make a difference. As a last resort I just re-installed the March firmware and the pads are back to solid triggering with any amount of pressure.


Same I’ve lost sensitivity here. Even at 0 for the threshold. Light push doesn’t work for me.

Very happy with undo and the other improvements so I don’t want to go back. Hopefully pad issue priority is raised and sorted once for all before there is no more firmware updates for a while.

I have this issue as well with my pads

I too have this issue with pads now missing, say, 1 in 5 firm hits. I have also rolled back to the Feb/March version. Hopefully a quick fix for the developers.


I am experienced this same issue with Pads but I noticed it only happens when using multiple pads when making a beat. If I am tapping out a closed Hat and then hit an open hat it happens or if I am banging a beat on the kick and snare it happens but not when I hit a single pad. It acts as if it is choking out every 5th or 6th note except my voice routings are fine and there is no room for this to occur.


How does one roll back their update? I put it on the root of the drive but nothing happened this time?

Hi - its exactly the same procedure taking the OS back as it is taking it forward.

  1. File > mount as USB drive (cant remember the exact terminology)
  2. from your computer, drop the old OS in the root folder of your S2400 shared drive
  3. from the S2400, press Back. You will then be asked if you want to update the OS.

thanks, Paul

1 Like

Thanks a lot! It worked and is now back to normal. Hopefully it gets fixed soon

1 Like

I’m having the same issue too with pads.

I think the others have made this clear but to be extra sure - the issue isn’t that the pad response isn’t as good as it could be it’s that they fairly regularly don’t trigger. As if the firmware is filtering out short or sharp hits.

The firmware loaded without a hitch and I’ve rolled it back and then re-installed it a few times to rule out an installation issue.

Here’s a few troubleshooting notes:

  • I did a moderately thorough run through the various sensitivity settings. The pads trigger reliably using the March 2021 firmware release but they don’t appear to be functional with the July release.
  • I don’t get the issue when tapping a constant stream of notes e.g. sixteenth notes at 110 bpm or more. It’s as if the pad is more likely to trigger if it doesn’t have time to fully recover from a hit.
  • If I totally bash the pads they almost always trigger.
  • Some of the pads have a noticeably different response but none of them is what you’d call playable.
  • Disconnecting USB and various i/o didn’t make any difference.
  • Running without the SD card didn’t make any difference.

In my case, to give a more detailed feedback, dynamic pads reponse has been improved. It’s way better than previously.

Where I ve lost sensitivity is in standard mode. It doesn’t respond really to slight pushes anymore.

1 Like

By standard do you mean dynamic mode turned off? Because yes this is the same for me. It’s being looked at.

1 Like

I have the same issues noted as well. It also appears that some Pads are not reaching full velocity and some miss a beat literally when tapping on it but in my observation this happens more when I am tapping multiple pads like kick and snare or open hat and closed hat. Is it possible since this seems to be a software issue that there is a “virtual bleed and choke” going on where one pads notes are bleeding into another pads notes and the machine is virtually choking them out?

yeah sorry by standard I meant dynamic mode turned off. Glad to know it’s being looked at :slight_smile:

1 Like

Same problem here after July update. With dynamic turned off pads are super unresponsive, like another user said before- a pad press/tap will often not register at all.

First thought it was related to the rate I was tapping at, but have confirmed that doesn’t matter- just totally random.

1 Like

^ same issue; dynamic mode generally ok (although these dynamic pads are not in the same league as my old MPC and ASR X pads). In standard mode (non-dynamic) they seem to have a 4/7 chance of registering. :frowning:

I became frustrated and hopped on my analog rytm for a break and the pads on there seemed like a godsend (never thought I would utter those words). I guess perspective is relative. -_-

1 Like

im having the same issue here,
any news from Isla if a fixer upper is coming up quickly to address this ?

1 Like

They’ve stated that they’re working on it in the Facebook group, and @iofflight one of the beta testers also said that it’s being looked at. I’m sure it will be addressed in a bug fix as soon as it’s worked out. :slightly_smiling_face:


Seems like when the pad volume is up it works better. Still trying it out.

I can confirm there is work being done on this.


I’m having the same issue with pad sensitivity.

1 Like