Pad responsiveness

Is there a way to improve the responsiveness of the pads when using the dynamic pads option?

I’m used to all kind of MPC pads and the S2400 seems very unresponsive when playing the pads in dynamic mode? Hard to explain, but you kinda have to hammer them and still don’t get full velocity. Hitting them gently results in almost no velocity, and there seems to be not much in between of that.

Also it feels like you need to hit them in the exact right spot (somewhere around the center of the pads) or they sometimes don’t respond at all.

I get it, there’s multi mode to get around that… but it feels impossible to get a natural groove with dynamic pads? Are my pads broken?



My pads feel the same way

Are they harder to press than the Elektron Analogue Rhythm?

I don’t have a rytm, but i have a dsi tempest, mpc1k (with the good pads), mp7, novation circuit, arturia minilab… All of those pads feel like they respond better to velocity. Non-velocity response is good.

Perhaps its something that can be fixed with more/individual calibration parameters and velocity curves but so far it’s just this “threshold” parameter that’s been implemented. Not sure if there are plans to add settings in future firmware releases.

The original Rhythm pads were hard. But they improved them on mk2. Im not sure this could be fixed by firmware though.

I feel like the pads are fine in how they respond (in non-dynamic mode), it’s just an issue in dynamic mode, it feels like you have to hit them with a hammer to get full velocity, and there is no inbetween… it’s almost silent or you hit them like a hammer to get them louder, medium velocity is hard to be found / achieved. I’ve tried adjusting pad velocity settings, but it feels like it doesn’t do anything. I’m using them in multi mode to get a more natural sound when programming / recording drums.


Maybe it is possible with the firmware.I know Korg have an app that controls velocity sensitivity on midi controllers. Hoping so.

1 Like

a scaling curve and user option for amount of velo required to reach max should be possible in FW. it is available in maschine and other gear on the fly so i don’t think it’s a hardware thing

@Mickey is that a possibility or am i way off?


@Mickey Hey Mickey,
Just wanted to ask if the Dynamic Pad issue as described above is on your radar.
I have been using multi-level which is a cool way to work, but there are times when a Dynamic pad would do the trick better, it is just so hard to get a velocity range using it, even when hammering hard.

It is on the radar.


Hello all, is it really something which can be solved on the software side or the hardware ? (which seems more logical with my limited technical knowledge-:slight_smile:

1 Like

Same here, tried adjusting the threshold settings but didn’t really notice a difference


I did the new update and it’s still happening, I hope this gets fixed, it’s really frustrating. I get a few miss fires here and there and there is no rhyme or reason? Played with the settings but no avail? Anyone have any suggestions?

1 Like

There are few people reporting that with the latest OS, pad triggers are getting missed. I just rolled my OS back to the Feb version as it was driving me crazy. Im sure something as fundamental as this will get fixed pretty quick then we can get back to the fun new stuff…

Can’t you just turn dynamic pads off and use them without touch sensitivity? I haven’t tried the new OS yet but that’s been an option previously.

Yeah that’s always available but there are some folks on here that just prefer to use dynamic pads.

Ok yeah I assumed that it was just the dynamic pads, but there’s a video on Facebook of someone experiencing the trigger issue with the dynamic pads box unchecked (off). Can’t imagine why that would change. I’m about to load up the new OS I’ll give it a try

Ohhhh I see! I didn’t catch that in the video. This thread is about the dynamic pads mode specifically I think, but I bet the pad threshold issue is what this bug report thread is.

Pad sensitivity issue after July firmware

I just though people were still having trouble dialing in the dynamic pads mode. But I guess there must be a bigger bug with the pads! I’m sure it will be worked out soon.

Question regarding the Pads and Midi Velocity - is this possible? I’m trying to use the S2400 to control a VST in my DAW and I don’t seem to be able to control velocity with the pad pressure?

(Apologies if this has been asked before, I’m a new owner so just trying to get my head around this beautiful thing)


Turn on dynamic pads under Global Settings