Midi gremlins

Hello fam, I’m sure the problem is user error but for the life of me I can’t figure out what the hell I’m doing wrong so I’m dragging my mistakes into public so you guys can make fun of me and possibly help solve my dilemma.

So, I have all my midi gear hooked up and I have a midi map built to trigger everything. So far so good, for drum sequences I want to trigger from the 2400 anyways so this functions as it should. But melodic sequences id like to play in from the synths themselves so I have a pad for each synth and if I hit it it triggers a note, and conversely if I play the synth I can see info coming in on the midi monitor section so I know everything is talking to each other.

I unfortunately don’t have a controller keyboard so I’m using my korg prologue as it’s class compliant and has a local off setting and does midi over usb.

When I use the prologue with usb, I get no info coming in on the midi monitor so I gave up on usb and am just using midi cables at this point.

I’ve watched the Alex ball midi videos and am setting everything up as I believe it should be within the sync section and corresponding pad settings section. But for some reason I cannot get the korg prologue to trigger midi notes for another synth in the studio using the midi focus.

Ask me stupid questions and I’ll tell you exactly what my settings are.

Enjoy this fat ass full moon and thanks for any help!!!


Had a similar problem. Class compliant USB host (Novation Launchpad X) did not work and I had no clue why this was.

Several months later a firmware update appeared. After the update the X worked with the S24. Could be that your synth isn’t full swing class compliant?

see this thread

Hmm, maybe.

I used to use a novation sl mkiii and everything worked but I sold it do to space issues in my smaller room. Thought ahh it’s no problem I can just use one of the synths to do what I need :sweat_smile:

But what’s got me scratching my head is it’s all hooked up via midi and still not working. I thought the class compliant thing was only relevant to usb. It’s hooked up via midi and I see midi info in the monitor so I know the s2400 reads what’s coming in, that’s what makes me think I’m over looking some setting somewhere but I’m missing what it could be. Or maybe there’s midi jitter in the lines and I’m not catching where or how or what’s causing it.

Other than global sync and individual pad settings is there anywhere I need to adjust settings?

Maybe the device id needs to change??
Does echo need to be on for some reason? Something other than telling global sync to listen to what comes in on channel 3 (prologue) via midi or telling the pad under the pad type setting that it’s a note trigger and channel 3?

I had a similar issue and turning Echo On fixed it. I also had to assign a unique device ID to the s2400, set my Keystep midi channel to that same device id number, and then use the midi focus for each pad I want to play. Works well now. Hope that fixes your problem.

Thanks for the suggestion, I just gave it a shot but still no luck.

Just to recap,

In sync menu;
Clock src - midi din

Control settings;
Control port - Din
Control channel- 3
Device Id - 3
Mmc input - off
Echo- on
Pattern change - none

Midi din jack;
Clock out - on
Notes out - on
Transport in - off
Notes in- on
Velocity in - on
Cc in - off

Nothing else on under the usb options.

In the pad H7 settings section;
Midi ports;
All tracks same- on
In from din- on
Everything else off

Track channel- 15
Pad mode- note gated
Pad channel - 2 ( this is the same midi Chan as the Moog synth I’m attempting to control)
Note- currently set to E4 but changes if I play the controller synth (prologue), which is set to midi channel 3
Dynamic - on

Midi focus on

So with this configuration if I play the prologue it automatically changes the pad channel to 3 since dynamic is on.

But channel 3 is the prologue and I’m trying to control the Moog on channel 2.

So if I switch dynamic to off, and change the pad channel back to 2, I only get the prologue to trigger the Moog if I happen to Play E4 note. It won’t just play the entire keybed.

Anyone else have any ideas?