Faders and knobs *not* changing parameters after sampling

After installing the new firmware (knowing the new functionality of moving a knob/fader to the current setting/position before modifying) I am occasionally running into an issue where the s2400 will not let me modify the pitch or filter positions after sampling/assigning to a pad.

There is no sequence recorded, and in the video the first sample initially allowed me to modify the pitch, but after sampling a second snippet neither will respond. In the video the slider you’ll see the fader moving, but no actual change being registered. I haven’t turned anything on/off or locked positions. I can record the knob as well, but it is doing the same thing. Powering on/off and reloading appears to remedy the issue, at least temporarily however, it has done this a few times now since updating the firmware.


I have not been able to reproduce this issue.
Can you give us step-by-step instructions to reproduce?

1 Like

It seems to just happen randomly (has happened x3 out of 20+ rounds sampling in the last two days).

Sample (“12 bit”, 26khz), assign pad (A1), save, adjust pitch on first sample, adjust filter

Sample new item ("12 bit, 26khz), assign pad (A2) save → faders no longer affect pitch, level, etc., And knobs have no effect on filter/resonance for either A2 or A1.

*Does not happen every time.

I haven’t thought to sample a third item in and assign to another pad to see if it continues.

Rebooting and reloading samples to the same pads → no issue in functionality, faders and knobs function as intended.


stupid question: have you pressed fader lock?

if not, oh dear :-o


No, the video is of exactly what’s is described above step-wise.

No lock applied, and unless a key combo has changed I am pretty sure nothing was accidentally pressed.


oh poo :frowning:

Man, same thing with mine!


Sorry, but also glad I don’t feel nuts now.

1 Like

if 2 of you can do it there must surely be others…

I am unable to edit the start point of a sample, do to the “Fader Catchup” never getting to the zero point of the beginning in the fader’s range. But, if I turn off “Fader Catchup” start editing works as normal. It seems to allow start editing with "Fader Catchup"after you toggle it back on.

1 Like

It would be nice for Catchup to be turned off during initial sample editing, as it’s one place you don’t mind having the fader jump to a location quickly.

1 Like

@finalisage That is unrelated to this bug report. However, are you moving fader 2 and 3 to the bottom?

@st1 Have you tried to move the faders/pots slower at the ‘catch up spot’? I have noticed that I could jump over this spot when moving fast. Moving slow allowed me to catch up.

@syah71 Jumping over the parameter value automatically catches up.
e.g. Fader never got close to parm value, but it used to be above and now it is below, so it must have passed through, so it is caught up.

I was being a little dramatic in the linked video, but yes - slow/fast. It isn’t happening all the time, so it is only a minor issue, but worth reporting.

Several of us have tried to reproduce this issue and have not been able to. If anyone has steps to reproduce it reliably please post them.

I forgot to ask - Is yours only happening intermittently?

In the last few days I have probably been on my machine 10-15 separate times, sampled ~ 30-40 files, and it has happened a total of x3 times. So very intermittent.

I’ve really only noticed it on one occasion. When I saw it happening, my thoughts were: ‘wow, that’s some wizardry shit going down’, or great programming.

Btw, I was in env mode and have not been sampling prior to the incident. I might have recorded a liveloop prior, but I’m not sure.

Might it happen to me again, I will try to create a reproduction path.

It only happened a few times the other day. When going to edit the sample before saving, only the right side fader would work. I had to hit on a few buttons to get the left side to cooperate. However, I’ve only used it once since I downloaded the new firmware update so I’ll let you know how it goes after a few more sample sessions.

1 Like

@SCT If you were in waveform edit, are you sure you were caught up with all 3 faders? There are 3 faders for the start, and 3 for the end. All 3 need to be caught up for the start or end point to move.