Edit sample start and end, save and BAM - distortion- SOLVED: -bug found though and fixed in FW

can someone explain this behaviour to me please? i can do this repeatedly on different files and channels

have i done something wrong ? i cannot imagine what, all i did was truncate a file and save it


Can you upload a project with WAV file where you have this happening? Also pls confirm which OS you’re running (I assume the Aug 12 update).

can’t load .rar file so need to share elsewhere

12.8.2021 OS

here is a link to grab project from the beast system

bank A pad1 is sampled 808 straight into machine - this file is not duplicated, this file was truncated 1st, then resampled and does not exhibit this behaviour
pad2,3,4,5 have all been loaded from SD card and treated to truncation and all display the flat distorted waveform - maybe you can load a file in of your own and repeat?

pad 2,3,4,5 are the source files before using the loop/slice page to truncate them - i figured adding them here so you could see how they should sound may help you to help me, i don’t know

i thought maybe it was the files being used but then ask myself why that would matter and tbh i have no idea, as i believe 2400 does its own magic if the file is not compatible anyway?

Pad5 is a sample from a maschine library and likely of a diff quality to pads 2,3,4 which are all zeroG files

This was blank project, no pad edits made, sampled the 808, truncated and resampled it, hadn’t even created pattern at this stage, loaded the files, edited and bam.

cheers @rozz3r

Thanks! That was really useful.

You have indeed found a bug.

The files loaded into Bank B are all 32bit float format and the S2400 doesn’t seem to like resaving them.

32bit float is rarely used, hence why nobody has reported it before. We will get it fixed, but I’d suggest using 16bit files (or 24) if only to save on RAM space. A 32bit file is about 3x the size of the same 16bit file.

Hope that helps :+1:


ok thankyou for the help

random coincidence that those very diff files were 32 bit - like i say some are zero g and the pad 5 was maschine library, i loaded another maschine library file from the same period and received none of the aggro, unreal and not complaining about 2400 there just a massive wtf that their format would change - i had no idea of the format tbf, how odd that it plays them but wont save them as a new format that the engine likes…i thought it sorted files itself, or is that just in the playback stage then?

ok maybe you can help me one more time, so if i reject the option of making them 24 bit because what PITA - i can use them and edit them but not save as ?


ok i tried resample, resampling them internally and saving them works, wonder what other methods i can use to cheat the system until a fix is created - got any ideas?

Resample is probably the easiest way. That converts them to 12bit files, after which you’ll be good to go. The bug is already fixed in dev.

Why any sample library is shipping 32bit files I don’t know. It’s totally unnecessary and just wastes space.

1 Like

yeah. sorry for that, I just fixed that bug when saving 32 bit float back to the card the file get mangled


yeah it’s all a bit weird - as you say, 32 bit ffs rofl

anyway cheers guys - removing video

1 Like