USB host not cooperating

Hello, not sure if this is the right place to post this but I’m having a hard time getting a midi controller keyboard to trigger notes over usb host port.

I’ve successfully used the midi din jack but with all the relevant options switched over to USB host it doesn’t work.

Checked options in both track settings and sync settings and switched over the control port but still there’s nothing via usb host. What am I missing?

which controller are you using and does it have it’s own power source?
Also have you followed this process Part 9: Sync, MIDI, USB - Isla Instruments S2400 Video User Manual - YouTube

Thanks for responding, I finally got it to work. It was something on the novation sl mkiii side that was causing it. It didn’t like the session template for some reason but when I started a new session(on the sl mkii not the s2400) it worked itself out.

I still don’t know why it wasn’t cooperating as they both had the same midi channel but it’s irrelevant now.

1 Like

Oh good I saw your message in the S2400 Reddit as well but had responded here first so thought I’d check back and see if you’d had any luck or further input.

Not to hijack this thread, but since @sircates problem was resolved…

I have 4 other novation products that I tried to connect to the USB H port:

  • Impulse 49
  • Launchpad OG
  • Launchpad mini
  • Launchpad X

The impulse works great!
The older launchpads do nothing, since they are not class compliant.
The X should work, it’s class compliant. However…
If connected before power up, I get a nice light show, but the X stays in standby mode.
If I connect it after the 2400 is already operational, it seems to work. So it gets enough power from the H port. The X shows normal boot behavior and after that it gets into note mode, great. BUT: no notes are being sent to the 2400. When opening the midi monitor on the 2400, all I see is program changes (when switching from note to custom mode). No midi notes, CC.
BTW: latest firmware on both the 2400 and the X.

What could be causing this?

Haven’t bothered looking further into it as it’s working now, but to any body having troubles with a novation controller, try again from a fresh session and see if that works. Cheers

Got my Launchpad X working. Updated the firmware from 1.04 to 1.05a and now it is finally working :wink: