Unit not booting up - troubleshooting

Hi there!

I’ve really enjoyed my second-hand Kordbot for a month and a half.
It’s a fantastic product which helps understanding western chords and harmony with its visual aid and ease of use, saving chords to memory, and more!

Yesterday night though, it didn’t boot when connecting it to USB.
I tried swapping USB cables and use a 9V DC PSU, to no avail.

Having neither dropped or spilled anything on it, I opened it up to check inside the unit.
It seems there’s some kind of oxidization on the board and visible components legs (mostly encoders).

I cleaned this to my utmost ability using contact cleaner and a toothbrush.

I live in Paris, and, granted, it sure does often rain, but these days haven’t been rainy at all and my apartment has not humidity issue either, so it could have been due to the previous owner.

I possess a multimeter and tried to check here and there, but being no expert I had not much idea what I was doing (dog_meme.jpg).
Also, it looks like encoder caps can’t be lifted of (?), so I couldn’t take completely disassemble the unit and a look at the other side of the board.

Did this kind of oxidization happen to someone else?
Is there a chance I could get it working again?

Thanks you for reading.