Kordbot not powering on. Tried new firmware, bootloader etc

Hi, hoping for some help on this. Kordbot is not powering on via USB to PC, Mac or USB power port or 9v PSU. The screen does display update messages when plugged in via USB, so the screen is working and the unit is receiving power.

Would like to get some clarity on what “reflashing” the firmware involves as other posts have suggested to similar problems? Is it just the firmware update from v5 as stated in the Firmware update post involving the Bootloader software?

I have gone through the full firmware installation process on Windows

  • Updated Bootloader
  • Run DFU process
  • Updated driver via device manager in Windows
  • Loaded firmware updates onto numerous SD Cards, tried all available firmware updates on all SD Cards.

Windows says that I have the latest drivers downloaded, that the bootloader runs successfully.

I’m presented with the following message when updating firmware from any SD Card and firmware update, trying mostly with the most recent firmware update (20211201). The unit then deletes the firmware .upf file and the screen goes to black.

Then, when plugging the unit in, the screen flashes white before going black and not turning on.

Would appreciate any possible help as this has consumed a large part of my weekend at this point. None of the update processes have worked on Mac.

Thanks
C