Kordbot Bootloader update unsuccesful on win and mac

Trying to update on firmware 4.12 here. On windows I get “No devices in DFU mode were found”.

On mac I get “ERASE_PAGE not correctly executed” at download stage.

Screen Shot 2021-12-01 at 15.57.07

Have replied to the support ticket you submitted :+1:

Thanks rozz3r do you think you could paste your reply here because it’s nowhere to be found.

My apologies, someone else opened a ticket with the same screenshot so I confused you with them.

We’re not sure what the “ERASE_PAGE not correctly executed” means at the moment. We’re looking into it. In the meantimes, you can probably get it working on Windows. It sounds like you just need to install the DFU driver in Windows.

Here is the entire process:

If updating from v5 or earlier, please use Part 1, then Part 2.
If updating from v6, please use only Part 2.

Part 1:

  • Download and unZIP the Windows or Mac Updater Application from Docs & Downloads – ISLA Instruments
  • (Windows only) Download the Windows DFU Driver from Docs & Downloads – ISLA Instruments
  • Download two files: kb_bootloader.dfu AND kordbot_xxxxxxxx_xxxxxx.upf from here: KordBot Firmware Updates - #7 by Mickey
  • Connect Kordbot to your Computer in DFU-Mode (there is a small hole underneath the Kordbot - depress using a pen whilst connecting to computer via USB - you should see nothing just a black screen - this is DFU mode - if you see the normal Kordbot screen, try again)
  • (Windows only) A driver needs to be installed in Windows Device Manager. Click on “STM32 BOOTLOADER“. Click on the Driver tab and then Update Driver. “Browse my computer for the file” - then navigate to the STM-Bootloader-Driver folder “x64” (for 64bit windows) or “x86” (for 32bit windows).
  • Run DFU_Kordbot application (from the Windows/Mac Updater Application ZIP)
  • Click “Load Update” and select kb_bootloader.dfu file
  • This can take some time - be patient. Wait for 100% complete.

Part 2:

  • Once this is finished, take the SD card from your Kordbot and copy kordbot_xxxxxxxx_xxxxxx.upf to it
  • Put the SD card back in Kordbot and restart the machine by unplugging the power/USB
  • The new update will install automatically on startup.

Let me know how you get on.

Thanks for copying over your reply.

Here’s what happened:
So I went ahead and downloaded the files again. When trying to update the driver in device manager I get “The best drivers for your device are already installed”
When I try to update the bootloader with the kordbot updater I get “No devices in DFU mode were found”
I then uninstalled the kordbot and driver in device manager and restarted. I plugged it back in in dfu mode and went to update the driver but when I point to the x64 folder (including subfolders) it says “windows was unable to install your STM32 Bootloader”
I noticed the file STtube.inf in the driver folder, outside of the x64 and x86 folders so I pointed to the enclosing folder and device manager was able to install a driver.
However when I run the updater and load the bootloader file, the process goes suspiciously fast and reaches “Programming complete”
Needless to say that if I put the SD card in the kordbot to try to update it nothing happens.

I also tried updating the driver with “include subfolders” unchecked but I got “please specify a different location” I also tried the x86 folder but the result was the same.

Not sure if this is relevant to your case or not, but I posted this in a Facebook chat for a video Brad did about the Firmware update a few weeks back

For me on Windows:

" Turns out that when I put the Kordbot in bootloader mode, it was showing up as STM32 BOOTLOADER in Device manager and it was under USB Devices instead of USB Controllers. The following link set me straight about switching that to STM Device if DFU Mode:


Should be all set. Now showing Beta v6.1 after putting the latest firmware on the SD card."

Thanks for that darrentwoods

I did notice that was the case when initially the updater couldn’t see the device in dfu. but once I reinstalled the driver it went under usb controllers and the updater was able to see it.
Switching drivers leads to the same results.
I’m wondering what the right driver version is, here it’s

@mrxndr The driver is definitely the right version. If you see “STM Device in DFU Mode” in Device Manager under USB Serial Bus Controllers then the driver is successfully installed.

So, then it’s up to the DFU_Kordbot application. You need to open that, click “Load Update” and select kb_bootloader.dfu file. It should tell you if the bootloader update was successful. After that, it’s on to Part2 of the instructions above.

If you’re still having problems, let me know on the support ticket you have open and I can walk you through an alternative method.

@rozz3r Thanks for your help with this.

I’d like to reply to the open ticket but I don’t see it anywhere. It’s not showing up in my account where it used to be. Emails only link to this topic.

I was able to load the dfu bootloader using the updater but when I do that it gets extremely quickly to “programming complete” like under 1second

If I then put the sd card in to update, the process never begins. I’ve tried several cards as well as trying different things in KordBot Beta Firmware V6 that users had success with.

I think the only option is to go for the alternative method you mentioned.

i could not get the updater app to see my kordbot on windows 11, no matter what driver i installed or bound the kordbot dfu interface to with zadig. what worked for me:

  1. get http://dfu-util.sourceforge.net/releases/dfu-util-0.9-win64.zip for dfu-util,
  2. unpack that somewhere, copy the bootloader update from the firmware thread there, and then open a windows shell (i use cmd instead of powershell, just by typing cmd into the windows search bar), go to the directory you unpacked the dfu-util, see that it actually finds the dfu port by running “dfu-util --list”
  3. run “dfu-util --alt 0 --download kb_bootloader.dfu” to flash the bootloader to the kordbot flash. (it was very quick, just a few seconds).
  4. wait a few seconds more and then just replug the kordbot. mine greeted me with a nice debug screen telling me the firmware was bad and needs an update. i just then followed the new fw update method, so:
  5. put the latest firmware from the firmware thread on the forum on your sd card , insert that into the sd slot and restart kordbot. it will then magically install the new goodness and transport kordbot from 2018 to 2021. :slight_smile: