KordBot Beta Firmware V6

KordBot Beta Firmware V6 - September 2020

Phew… what a wait. I’m sorry.
Most of you already know the reasons why, KordBot firmware development is now back on track.

Ok, so what’s new?

  • Huge amounts of code re-write, KordBot now happily sits with an idle CPU around 60% of the time.

  • Greatly improved key response.

External MIDI clock sync
Completely re-written, KordBot is now super tight.
You no longer have to ‘Arm’ your first chord.
KordBot will accept external MIDI clock from both USB or MIDI DIN.
Pressing ‘X’ with the arp running (on either internal, or external clock) will stop the arp.

HINT: I like to have quantise set to 8, as it helps you to get the arp running ‘in time’ with your music, as well as just at the correct tempo when you hit the keys.

External MIDI input
You may now trigger the KordBot note keys from an external controller, with velocity.
Works from USB/MIDI DIN
Currently, will ONLY receive external keys on MIDI CH 1

HINT: As memory pad triggers still have their own setup screen (SHIFT + F4) remember to NOT use MIDI channel 1 for these, as they will clash with the note keys.

Update Via SD Card
This will be the method of firmware update moving forward. Which will make the whole updating procedure much simpler for everyone. In the very worst of circumstances (bricked KordBot) you will always be able to fall back on the old method.

Update Instructions

This firmware update must be performed in two stages (subsequent fw updates will just be a case of dragging a file onto your SD card)

Firstly, using the old method (WE HIGHLY RECOMMEND DOING THIS ON WINDOWS) please update your KordBot using this bootloader firmware kb_bootloader.dfu (29.2 KB)

If you need a refresher on how to achieve this, follow along this video:

Once you have completed this step, download the main firmware application
kordbot-5a4f1ad-20200905a.upf (704.5 KB)
Place this file on a FAT32 formated SD Card and then insert the card, gold contacts facing up, into your KordBot

Connect USB and power up, You should see some text on the screen showing you that KordBot is updating.
The update process should take around 10 seconds.


Let us know how it goes, did you update ok?

1 Like

I tried updating the bootloader.dfu file following your instructions on both Mac and PC and it bricked the Kordbot until I reinstalled V5. The first image is what the screen booted to after the firmware update and the second image is what it shows when I power down and restart. image


Mac user here- I got the same error after putting in DFU mode. HOWEVER, I was able to fix by reformatting my SD card to MSDOS FAT (was EXFAT from factory). Once I did that I upgraded successfully without having to revert to V5.

Windows here - updated to beta 5 without problems. Put update 6 on sd but kordbot just runs as usual, no text at the start and still on 5

Be sure you put the KordBot in DFU mode with the updater and the new bootloader. When that is done, your Kordbot should only show a “terminal” window black on white text…

This is not bricked, it is the bootloader, working, and looking to the SD card for the ACTUAL firmware update, please see that there are 2 downloads in the above post.
It seems like you only flashed the bootloader.

you shouldn’t be updating to beta 5.
Please check the instructions again.

I seem to have the same problem as @mistereventhorizonz up there. I ran the bootloader with success but when I tried to run the upf-file from the SD-card it does not detect that the SD-card is inserted. Same exact screens as he had.

I’m on a mac. We have 5 macs in our house, not a single windows-computer.

[Edit] I downgraded back to OS 5. Now it works again. I’ll try again some other time. Now I’ll open a beer and stream the new Bill & Ted movie to soothe my nerves. Have a great weekend.

1 Like

@Wolf-Rami is the SD card formatted to msdos format? I had the same issue as you until I reformatted it with Disk Utility.

1 Like

Yup. I formatted it twice or thrice into different (pc)formats but none of them worked for me. I got so annoyed that I decided not to ruin the whole night fighting with that and decided to try it some other time. I’m perfectly happy with the 5 beta firmware. I’m in no hurry to update.

I struggled to get the application to work on a Windows 10 machine. I could see the unit in the device manager in bootloader mode but the loader SW couldn’t find it. I was 100% successful in using a MAC runing Catalina to get the first part loaded. I used a 4GB SD Card for the second step and now running V6, nice splash startup BTW!

BTW, I think you can remove the BETA Tag from the firmware…


I figured it out. The issue was finding a card to work. 3rd one was a charm. all is well now. thanks!


Thanks for the tip! I have a bunch of cards in the drawer, some of them unused. I’ll try a different card tomorrow too.

1 Like

yeah I was trying to use a few 2 and 4 gb sd cards I had laying around because the manual describes using those as a system card and none were working but as soon as I went to the 16 gb sdhc card it was all good.

1 Like

I’m having a prob making a category to save the settings?

The sd card has mounted ok

It seems the kordbot cannot format it either?

1 Like

Mac user here,

I followed the video, installed the bootloader firmware and got the same error a lot of other people got on my Kordbot.

My issue was I was using the 500GB SD card I got for my S2400 (when that beauty shows up). I pulled an old 8GB card out, tried again and it loaded up just fine.

Hm no luck with step one here.
When I press “load update” it’s really fast, not erasing and writing blocks, but says complete. But I never entered bootloader…