Triggering pads in Ableton via midi

Hello I am trying to trigger my s2400 in Ableton live but i’m not getting any joy, so far I have got the midi signal triggering in Ableton when hitting a pad on the s2400 but with no sound . All I want to do is create a midi drum sequence and record it to audio in Ableton. if someone here could help explain to me in simple terms how to go about this . Much appreciated in advance to whoever can help.

First off, I have not tried what you are describing, so I can’t speak to your exact wish, but…

Check in the sync menu on the S2400 and look at your “MIDI Jack Settings” for whatever jack you are using in and out. I usually find that the “Notes In” is my issue when I start sending MIDI to the S2400 and get no sounds. Page 72 of the manual is where this info is at btw.

You may run into an issue where looping of the MIDI data occurs if you are trying to use the S2400 to send midi to ableton and then expecting ableton to in turn trigger the S2400.

I suppose the other part of the equation is that you have to set up an audio track in ableton to get the sound back from the S2400. I assume you know how to do that and then record enable or monitor that track from within ableton.

Some more details about the exact part of all this that is giving you trouble might help for some more specific advice.

This might help with what @merk was saying about midiloops:

thank you for your quick reply ! check the jack settings tried checking on and off with notes in still not getting anywhere. I am going to have a check in the manual page 72 forgive me for my ignorance ,this is my first time powering up the s2400 so im still figuring out how to use this machine. this is what ive got going on the s2400 main outs going into my focusrite , midi in/out from s2400 to focusrite, focusrite to computer running live 11 usb cable connected to s2400 to computer.

Thanks ive got the midi channel set up the same way you are showing in the pic . midi showining (triggering)when touching pads or midi controller but no sound !

I cant find a page 72 only 43 pages!

Make sure you have the latest manual. I’m not at my computer right now to tell you exactly where to look. Pretty sure it is on Isla’s main site. Not the forum one.

Are you getting audio from the S2400 without trying to trigger it from ableton. I would take this in stages to try to figure out one thing before moving on to the next step. Let’s make sure you can play samples through your audio interface into ableton and hear them first.

1 Like

One more thing you might look at on the S2400 is at the bottom of the “Sync” menu. It’s on page 75 of the manual, called “MIDI Monitor”. This will show all MIDI messages coming into the S2400. It might help you with troubleshooting the issue.

I believe you also need to go into the track settings for each track on the S2400 and choose which MIDI channel that track responds to (page 73 - Sample Tracks Map). I think by default the tracks may be set to different MIDI channels so that you would not be able to play them all from one ableton track. You will probably have to go in and assign each track on the S2400 to e.g. MIDI Channel 1 and Note C3, then the next to MIDI Channel 1 and Note D3, etc, etc.

Hopefully some of that makes some sense and you can start using the S2400 how you want.