PLEASE HELP: s2400 into Ableton 12 - usb audio error

Hi there,

I have been trying to connect my s2400 to ableton to track all tracks individually.

I have watched loads of videos on how to track out all the individual channels into ableton and followed all recommendations

I have input device as s2400
Output device as headphones (because i work late and people are sleeping in the house)

Everytime i play on the s2400, all sounds play on all audio tracks in ableton.
I have mapped all the audio tracks in ableton to the respect mono inputs (Track 1 = Mono Input 1 etc.)
I have reviewed the global settings for first and last usb mix order.
I have assigned each pad to the respective output

When i enable FIRST, it plays all sounds in all audio tracks
When i enable LAST, it groups all sounds on a single audio track, despite whatever settings i have in ableton or the respective TRACK SETTINGS for each pad.

I had even tried to recreate this issue with a friend over zoom on their s2400 and macbook but they were able to map it correctly with the exact same settings.

I am really unsure what the issue is and would love any guidance on what/why or how i can fix this


That’s because it works on mac, not windows. Never send a video to do a page of text’s job. :smile:

ASIO4ALL is a possible workaround

Hello and welcome!

Hey kid Missive,

Sorry! Must have not been clear: I am also running this vid MacBook.

This is why I’m so confused!



Is it brand new? Maybe things have changed?

Hey Kid Missive

I bought it 8 weeks ago. MacBook is also brand new.

Everything is brand new. I’m so confused

Can you confirm that on your laptop, in System Preferences > Audio > Inputs, you cannot see multiple ISLA Instruments devices?

It is certaily possible that the hardware of, like Apple silicon era machines has changed. That would be my guess because we can never have nice things in this world. :worried:

Either way it would be wonderful to see some support from either company, or if any forum members wan’t to chime in with their experience.

EDIT: If it’s any consolation, the audio quality is better if you use a mixer or dedicated interface with the actual channel outs. It makes a noticeable difference in punchy character. I used USB for a while with my ancient macbook air but now I have a decent studio mixer.

Yes, I can confirm that only one ISLA instrument device is being recognized.

Yes, my plan is to set up a studio mixer but in the interim, I am really just trying to get a workflow ready so i can track out my arrangements into Ableton.

Apple M3 Max is the laptop and is 4 weeks old.

I am considering that the s2400 may be faulty because I am unsure what else it could be.

Quick update: I have tried to replicate the problem with my old macbook - (intel based) and everything worked instantly. I think there is an issue between s2400 and the M3 Max Macbooks. Unsure what the solution is but if anyone has got this to work, would be grateful!

I am on an Apple M3 Pro (MBP Nov. 2023) and testet with both USB Mix Order settings in Reason and Audacity. Everything works as expected.
(BTW: I am using a short “not-so-cheap” USB-C to USB-B cable, no host or adapters.)


Thanks for the double check, EFGE, i have no idea why mine is not playing nice.

I have new USB C to USB B cable, directly into the m3 max and it sounds absolutely awful. I will keep troubleshooting to understand the problem


I’m not sure if this matter but isn’t it a Asio Driver?
Maybe try downloading AsioForAll(Maybe its called Asio4all)
It shouldn’t crackle and such unless there’s an issue with the buffersize.
That or just actually a driver capability issue.