Something weird happened to my S2400 - Anyone Else?

I was sampling some vinyl and after setting the start and end points for my sample I clicked the “Save” button. The button lit up but the screen stayed on the waveform (it didn’t change to the save menu). Then I realized that the S2400 was locked up / frozen. I turned it off, waited a few seconds, and turned it back on. It was completely dead, nothing at all lit up, nothing. I toggled the power a few times and started thinking that it had completely failed. Then I unplugged my USB typing keyboard, disconnected the MIDI cables, and removed my memory card. I tried turning it on again and it booted up. I turned it off and inserted the memory card and then powered it on again. It seemed fine. I got back to sampling and reconnected the USB keyboard so I could type in the filenames. Everything worked fine. I did not reconnect the MIDI, but I doubt that caused the issue.

Anyone else ever had the same thing happen? It was weird and makes me nervous now. Possibly a resettable fuse that tripped and took a minute to reset, but what would have made it trip anyways?

This may or may not be helpful but…

I’ve never experienced this with the S2400 but often with computers.

You mention unplugging the USB; My pc does not like my Launchpad X. Something about the USB implementation for that device seems to bug my power supply out especially after power outages (although the pc is on an APC battery backup and doesn’t actually lose power). Unplugging and replugging the X solves the issue. I have also had this problem in the past with a Novation Nocturn.

A better troubleshooter may be able to glean something from this

1 Like