2 bugs to report

So on my end I’m encountering two fairly repeatable bugs.

  1. At some point while loading single samples the unit will freeze and I have to reboot. This has happened 4x over the last 48 hours. I doubled checked that it wasn’t a specific file that was causing it. As far as I can tell it’s random and one sample I tried to load that froze the device loaded perfectly fine on the next pass.

ETA I just experienced a freeze while saving a project as well.

  1. I keep getting random disconnects while in USB MSC mode. I’m trying to transfer sample libraries and the disconnects keep happening. My mac shoots a message saying I’ve disconnected improperly.
    a. I’ve changed the sleep time to 50 minutes
    b. I’ve tried just transferring one folder at a time
    c. I’ve reformatted the SD card which is a San Disk Extreme Pro 128 GB.
    d. I tried to work around it by loading the SD card from the computer but of course it’s read only so no go.
    e. also I can confirm it disconnects at random without transfers or any activity of any kind and I tried different usb ports and 2 different cables.

ETA: on the off chance it was some weird behavior with my Mac Pro (10.13.6) I decided to see how it would behave with my MBP which is running 10.15.7 and transferring directly from the main HD and not an external HD. Same behavior. I reformatted the SD card on my mac using ms dos fat32 and now it is writable from the computer so I can transfer files outside of the S2400 ecosystem. It’s a workable solution for now.

I can try again on my Windows 10 machine tomorrow and see if it happens there.

That is what I’ve encountered thus far. Thanks Team!

how long is that USB cable? Can you show me a pic of it?

50 feet is that an issue? J/K one was 5 ft and the other 6ft. Should I try shorter?

if you have shorter it’s worth a try.
That said, are you dumping gigs of samples across??

it was large initially yes. Then I backed off and tried smaller dumps, and then I just connected and did nothing and drops were still happening while no transfers were taking place. Reformatting the SD on my mac seemed to help that a bit and I had slightly more stability late last night. I’ll have to play around some more. I’m going to connect it to my windows machine and see if that changes the behaviour at all.

48k or?

do you have a different SD to check against? just trying to think what i would do

i know very little about these things but some machines prefer the none super versions, as in the best is sometimes too good - not saying this is the reason but i know if i try a beast in my 808 it rejects it

1 Like

also, all usb cables are not equal

my elektron cables are brilliant, try a normal low cost cable and i have usb issues

1 Like

I agree it could be card or USB cable. Please keep us posted as you find more on this. :octopus:

I have a 32 gb card in my MPC that may function better than the 128gb card. I could try swapping it out and see if that makes a difference. I tried 3 different USB cables, two different USB ports each of my two different macs but it was the same behavior.

I did plug it into the windows 10 machine I just wanted to see if it would stay connected it seemed to be more stable there. When it’s attached to the macs just even deleting something from the card can cause a random disconnect.

A shorter USB cable may work but it won’t be a solution long term as the Mac pro tower is on the floor and 5 feet is necessary from the desk to the floor and shouldn’t have any bearing on connectivity.

Anyway I’ll do some further testing today and see if I have anything else to report back.

Okay here is a follow up and this is what I suspect is happening. The S2400 connects and transfers fine on the PC. Since this has been an issue on both Macs running different OSs I was fairly certain the issue isn’t the S2400 but something the Mac isn’t liking about the S2400 connection. Apple seems to strictly control USB powering much more than hubs and more so than most PCs. I don’t know what the power draw is in USB MSC mode but I’m assuming it’s more than the Macs like. I have an external powered USB hub and it seems more stable on that than connected directly to the mac. So for others on a mac system I recommend using an external powered USB hub that is of decent quality like Startech.

Here is what I’m using.

1 Like

interesting result thanks

i use a dinosaur pc, and i mean dinosaur :crazy_face:

My macs are not that new I have a refurbed 2012 tower and MBP 2015 model. The PC is 1.5 years old and truly a great machine that I built for gaming and IT labs. I don’t use it for music because I hate the driver issues and connectivity problems of gear on PCs and I’m almost 95% hardware based. If I was ITB the PC would be the better machine for sure.

I am getting a lot of freezes while saving projects as well.

1 Like

Saving while playing sometimes causes a crash and corrupts the project.
In the next firmware update, the machine will prevent saving while patterns are playing.
Hopefully this change is temporary while we work to figure out the issue.


That’s good to know however I’m not playing while saving. I’m still running into crashes while loading sounds and saving projects somewhat frequently. I don’t know if longer samples are a culprit but it seems as if they might be.