Pops and Clicks during sampling

I have tried a million different cables and instruments. Everything I record has pops, clicks, and drop outs in the audio. Samples played from the sd card sound fine. My samples say good after sampling. No response from support. Any ideas? When I first plugged it in, the sampling function was working. The SD card is not the culprit as the pops and clicks are present when monitoring the input, even with the input volume super low.

Can you post some audio or a video of what you are describing?

I can on Monday, but honestly, I think it needs repair. I’ve updated the firmware(was already the latest), tried every cable and source I own, and tried a different Sd card. No pops and clicks on audio played from the sd card. Only stuff that I record. Messed with all the gain multiplier, trim, other settings to no avail. Nothing is clipping.

Also, I’m sending it midi from a Novation Launchpad and midi clock from euro land via Pamela’s New Workout. Not sure if that could cause a leakage or some gremlins.

This may or may not be helpful but I’ve noticed that midi via usb has some interesting side effects. For example, if I am done with the 2400 and I cut it off, it will cause my DAW to glitch out, almost sounds like a buffer error, then restarts the session from the beginning. This, of course, is bizarre because I don’t have any midi messages being sent or received when I do this.

I turned it on again today, and noticed no pops and clicks after jiggling the trim adjustment on the back. I’ll keep an eye on it and see if it comes back. I may have a faulty trim pot.