[Solved] No Auto-Installation on Mac/ and No SD Card Showing?

Hi there,

I got my S2400 a couple of days ago and I’ve not been able to get it to sync (auto-install) with my computer. I followed the instructions in the tutorial: formatted SD card; connected to computer etc… but at that point where it said “allow any auto-installation that needs to happen to happen” - nothing happened. And, although the S2400 says that the SD card is ready for use with the computer, the disk utility on the Mac says there’s no external device detected.

Any suggestions would be greatly appreciated as it’s frustrating having such a great unit and being unable to use it, or even perform the recommended firmware update.


Easiest way is to put your SD card into your computer, copy the FW update file from the computer to the SD card (root directory), then put the SD card into the s2400, boot it up and it will ask you if you want to update the firmware.

1 Like

Thanks so much, I’ll have a bash at that then… :+1:

To have your computer recognize the S2400 SD card as an external drive, you have to put the S2400 into MSC (mass storage class) mode. The option is on the File menu.

OK, I’ll have a go at that… I’ve managed to install the firmware manually but only through the PC… I’ll try and use MSC mode instead… Thanks!

case closed?

1 Like

Sorry for the delay in feedback… Yes, that’s sorted it… Not sure why but the first three times I attempted this it didn’t work, but it’s just popped up on my screen now… Maybe I was exiting MSC mode before it loaded?

Thank you everybody for the help! :smiley:

1 Like

My mac or pc will not read my SD card. I tried MSC mode multiple times and it continues to state " SD Card Not Inserted". Different cards was used as well as wires.

Have you tried formatting it in the ‘File’ menu? The manual says it should be FAT32 and that it can be formatted using the format option un the File Menu. Alternatively, have you tried inserting your SD card directly into your computer on a stick (maybe this’ll work)?

Other than trying those things I’m not sure…

Yes, I tried everything listed on the forum. As well as your recommendations. Everything work except getting it in MSC mode. It keep saying insert Sd card while the card is actually in. The machine allows to me to save ,load, format and read files but will not work in MSC mode.

when you go to FILE → USB MSC MODE, a screen appears that says “USB MSC MODE … press back to Exit”

while in this screen (DO NOT PRESS BACK), what does your PC or MAC do, does it report a USB mass storage device?

It states "No SD Card inserted " on the screen. Also it does not read the mass storage.

The only way transfer my files is by using my computer. Im currently using Sandisk Pro 128. I tried 5 other brands but no luck.

The S2400 readable by the computer at all.

ok, lets back up a second.

  1. go to FILE
  2. select USB MSC MODE
  3. press the encoder

do you then see this screen???


this IS USB MSC MODE, do NOT press BACK.

now, you see the above screen, the S2400 should appear as a USB drive on your PC/MAC

2nd question: while not in this special USB MSC MODE, the S2400 should appear as a MIDI device on your PC/MAC, does that work for you?

It shows “No SD Card Inserted” when I press the encoder for MSC Mode. My windows and Mac do not appear as a midi device neither.

Its almost like its missing the usb drivers.It freezes after a second try. No buttons will work and I end up shutting it down then turning it back on.

ok, one more question: when you unplug the USB cable on the back, and you go to MSC MODE, do you also not see the screen that I posted?

It says " No SD Card Inserted"

OK, one more thing. on my machine, when I remove the SD card and I try to go to USB MSC MODE I get the “no SD card” screen that you posted. but not with a card inside.

so, when you plug the card and go to “Browse Files”, do you see this ?

Browse Files
[] Internal
[] SD Card

Yes , I see Internal and SD. Now the SD Folder disappeared.

You think there may be some type of software missing ?