Midi Sync via Midi DIN jack

Hi Isla Team. Love your work. Have you been able to have the S2400 chase / sync to a daw via Midi Beat Clock? I havent been successful yet. Sending Midi Beat Clock via Midi cable. I have set the sync page correctly. I will keep toying with it. Cheers.

1 Like

I would also like to trigger the S2400 to play from my DAW via standard midi. Not sure this feature made it to this Firmware version. Although using the USB midi sync works to start the s2400 when I hit play on my DAW

i just tried it with the latest firmware. Still not slaving to my DAW which is sending midi beat clock via a midi cable. All my other gear is syncing fine.

MIDI input is still in development. Like, right this minute.

I don’t want to be the RTFM guy, but that is stated in the manual. :wink:


Thank you Mickey! This thing is so fun I havent had time to RTFM!


how far off is external midi syc? im kind of on hold at the moment using my s2400 because i need it for what i want to do with it.


Done in beta. Will be in next release.


Dear Isla geniuses: when will you drop the next update? Jonesin here bigtime for that MIDI sync!!! Cheers u rock.


Installed the latest OS (020821) but no note play or transport control from MIDI DIN. Checked MIDI cables and it’s good. Works using the USB B. I watched the latest Video Manual and set all settings correctly (I believe):

Transport In - Checked
Notes In - Checked
Velocity In - Checked

@teqnotic What device are you sending start/clock from into the S2400?

I’m using an Impulse 25 Keyboard MIDI out connected directly to the S2400 MIDI In. Sending MIDI notes on Channel 10. Doesn’t trigger samples and doesn’t start playback when I press play on the Impulse 25

That should work. Has been tested a lot and shown in the video lesson.
Is the cable definitely good (tested with other gear)? Sorry to ask the obvious, but it is plugged into the correct jack on the S2400?

I did some troubleshooting and discovered that whenever I send an MMC transport command (such as Play) from my Novation Impulse 25, I lose MIDI control on the S2400, and have to reboot it to work again. Guess the S2400 doesn’t like the Impulse 25 MMC messages.

Also, my RME Fireface MIDI port doesn’t work with sending MIDI messages to the S2400.

Anyway, I’m good with being able to Start/Stop and play notes on the S2400 from my DAW

@teqnotic Can you record/monitor the exact midi message the Impulse is sending?
It would be a big help to have the message so we can figure out why it is confusing the S2400.

You can use a tool like MIDI-OX (for Windows) or Snoise (for Mac), or ReceiveMIDI (cross platform).


From Impulse 25:

Sending Note C:
00000E4A 12 14 99 24 48 10 C 2 Note On
00000ED8 12 14 89 24 00 10 C 2 Note Off

Sending MMC Play:
00012A59 12 14 F0 Buffer: 6 Bytes System Exclusive
SYSX: F0 7F 7F 06 02 F7

Sending MMC Stop:
00014186 12 14 F0 Buffer: 6 Bytes System Exclusive
SYSX: F0 7F 7F 06 01 F7

Thank you @teqnotic !

Those messages look normal.

You mentioned that your RME audio interface does not work. Do any other midi controllers work for you when connected to the S2400? I am wondering if it is a hardware issue with the S2400 MIDI jack.

I researched the RME MIDI problem, and it’s a known issue that was never fixed. I’m able to play MIDI notes from my Maschine Studio. I do not have another controller to test the MMC commands, however I’m able to play/stop the S2400 from my DAW- Studio One V5 using MIDI clock start

What do you have the clock source set to?
If clock source is not internal, then transport messages can only come from the clock source. For example, if the clock source is USB, then transport messages from DIN are ignored.