MIDI recording channels

I am having trouble understanding the capabilities of recording MIDI.

When I first set up the S2400 in my rig, I was using a single MIDI controller and had everything successfully set up so that the controller keyboard would send on the same MIDI channel that the control channel on the S2400 was set to receive, then setting up each MIDI track to use unique MIDI channels and using the MIDI Focus button to choose which part I was recording from the controller keyboard.

I’m now trying to remove the controller keyboard from the setup and instead record MIDI directly from a few different MIDI keyboards (each set to a unique channel). The manual and video manuals, as far as I can tell, only go over controlling the S2400 via the controller channel, and I just can’t get a functioning setup using multiple sources.

The first thing I ran across is none of the MIDI tracks on the S2400 respond to MIDI except when the MIDI Focus button is pressed and the MIDI channel being sent to the S2400 is the same as the controller channel setting. I can’t tell if this is a feature or a bug, but it feels like a bug. My expectation is that the track should record either/both the MIDI on the controller channel OR the MIDI channel that the track itself is set to.

To try to work around this constraint I am using a MIDI filter to map the unique channels that each keyboard is outputting to the S2400’s controller channel. This works well except that there is a MIDI echo only when recording. I have the echo setting in the controller channel setup disabled, and I’ve also tried turning on/off the DIN Inputs on the MIDI track to no avail. I have removed all devices from the setup except for the S2400 and one single keyboard and still the echo persists (again, only during recording).

I feel like I’m either missing something or fighting a bug. Anyone have any insight here?

To clarify this all using the MIDI DIN ports

Another data point: enabling MIDI Echo on the S2400’s control channel replicates the issue of MIDI echo/loopback immediately that I otherwise see only when recording MIDI when MIDI Echo is disabled. So this seems to support that MIDI is being echo’d from the S2400 during record, and I’m trying to prevent that from happening.

Another observation: In the MIDI track, if I record with the DIN output disabled, the echo goes away during recording but then you have to switch DIN output back on for playback

They should, I switch between both methods all the time

controller connected to USB host for midi input focus and a standard midi cable from controller to midi DIN.

You can either change the controller channel to play the corresponding track, or press midi input focus. I only do this because midi input input focus doesn’t work while sampling and I have to fall back to the other method (i don’t use the looper)

go to the Sync menu and check your midi jack settings, maybe something isn’t checked there

After more testing I just can’t get a MIDI track to record MIDI from the channel it is assigned to - it will only record from the control channel.

I did finally get settings figured out so that the MIDI echo I was seeing has been resolved and was just a byproduct of my routing, but the routing is to workaround the constraint of the control channel

Is MIDI Focus turned on? (A button lit)
When MIDI Focus is on then only messages from the control port/channel are accepted.
When it is off, then messages are routed to the tracks based on MIDI channel.

1 Like

That was it - I was always using MIDI Focus! If I have that disabled then it records the oncoming MIDI on the corresponding MIDI track with that channel assigned. Thank you, that was driving me nuts!