MIDI from logic not firing pads

Hey guys, I had this midi problem not firing pads, then it worked briefly. Now it’s not working again. I shot. A video showing what I have. Please let me know what I should try. Thanks! (And in the support ticket I was told to shoot a video and post up in here).

Video of what is not working. https://youtu.be/At5EATuXYSk

Second test. https://youtu.be/JBatSHQ0hrg

Lastly, this kit is really sweet!

MIDI monitor shows you are sending on channel 15. But, the config for A1 says channel 10.

Sorry I was on channel 10 but since was having issues I tried switching to 15. And had left it in between on the last save. It’s now all at 15 and same problem.

Any other thoughts? TIA

It looks like your note numbers don’t match. The midi monitor said C7 and D7. But that is not what you have the tracks assigned to.

If you would rather work with note numbers (I would), then Press F2 in midi monitor to switch from note names to numbers.

1 Like

correct. they are two octaves apart. (I had posted on FB about that). im assigning the pads to what the midi monitor is showing, since I figure S2400 knows what its receiving. I have no idea why those octaves are not matching up.

Please switch to note numbers. There is no ambiguity then.

How do I do that? (im happy to, just not sure how)

Press F2 in midi monitor to switch from note names to numbers.

Looks like note 84 for track A. I see it in the monitor and the assigned but still does not fire.

What should I try next

Make sure your tracks are mapped to notes 84 and 86. Like this:


They are. Still no joy though.

Anything else I should try?

Hey @Voodoodoctor I spent some time trying to reproduce this here, and here is what I found. Logic is kind of finicky with midi out over USB for some reason. After initially not seeing any activity in the 2400 from Logic, I ended up unplugging and reinserting the USB cable which seemed to wake logic up and activity and notes were triggering as expected. My S2400 was set to channel 15, and I set Pads A1-3 to notes 34-36.

I’m using USB B for midi- are you also using that or midi DIN? Maybe try what I did with the usb cable while logic is open and see if things improve. Post back and we can work from there.

Im using a E Magic Unitor 8… so its USB to the Unitor, then that has 8 DIN type MIDI ports. I have not tried connecting the S2400 over USB yet, but ill try that tonight. :slight_smile: thanks for checking in.

Good news on using USB for MIDI. That worked right away. The mapping worked as it should! Thanks :slight_smile:

The MIDI through the DIN via the unitor still does not work. But Im happy to run MIDI over USB.

Lastly I was able to trigger pads over the MIDI DIN from an old EMU x board by me just pressing on the keys. Still strange that the S2400 sees the notes in the MIDI monitor from logic over the DIN but doesn’t trigger them.

If there is something you all need me to test to troubleshoot if it’s a user error or a bug just let me know. Meanwhile I’ll rock out the MIDI over USB.

Thanks all

1 Like

Glad to hear that @Voodoodoctor - I have a midi DIN interface as well that I will try to see if it is something specific to the DIN jack. Do you have a midi keyboard or something that you can use to test directly from the keyboard to the S2400?

yes, I did that last night and I was able to trigger sounds on the S2400 from the Midi Keyboard. So the DIN is working on the S2400 which is good. Again the really odd thing is that the notes were being detected in the midi monitor. Which is why I was thinking a bug, since the mapping and the monitor all match up. I realize unless someone else has my setup it can be hard to chase down. Im good with rocking out the USB option for me so im ok for now. So its really just a matter of chasing it down now to help with the product in case it is a bug. If there is anything you all need me to test to help I can, just let me know.

1 Like