Kordbot SD Card Firmware issue

I’ve successfully got the boot loader on my Kordbot but can’t get the Kordbot to update with the upf file on any SD card. I tried 3 different SD cards last night. Then I went and picked up a new SD card today and it still doesn’t work. All of these cards are formatted as FAT.

When I insert the SD card with the UPF file on it this is what is shown on the screen…

Kordbot Bootloader
[SDIO] init
[SDIO] MaxBusClkFrec 50

I just tried another card (microSD with adapter) and it also didn’t work. Now at a total of 5 different SD cards not working.

btw, I’m a backer from the original kickstarter campaign and I haven’t tried to update it till now. Not sure if that has anything to do with my issue. I’ve followed the instructions exactly, multiple times, and just can’t get it past this screen with the 3 lines posted above.

Would greatly appreciate an answer so I can get this thing up and running again.

My best guess would be that something is wrong with the way your SD cards are formatted if you tried 5 different ones

Pretty sure its not the formatting. They are all formatted fat32. The brand new one I got from the store came as Fat32 and i left as is, did not reformat it on my own computer. Some of my existing SD cards I formatted on my PC and then also tried formatting on Mac, always Fat32 as recommended.

How do you format as FAT32 on a mac? You said it was formatted as FAT, now it’s FAT32. There’s a difference between FAT, FAT12, FAT16, FAT32 and exFAT.

What’s the partition table looking like?

I had formatted on Mac with Disk Utility as MS-DOS (Fat) as “Master Boot Record” which didn’t work on any card. I also had formatted all of them as Fat32 on my PC and that also didn’t work. I also bought a brand new card, left it formatted as is from the store and that didn’t work.

I see. What’s the capacity of those SD cards that you have tried? Something I worked on had a bug where only smaller SD cards would work. I am not saying this is the case but it sometimes happens

Is this all that gets shown on screen?

Yes that is it. Even when I leave it plugged in for a long time.

It’s definitely looking for SD card at that stage in the boot. It’s as if it can’t see any card at all (regardless of formatting). If it was struggling to mount a card (due to wrong format) it would give you a Mount error after the messages you’re seeing already.

Sounds daft, but are you definitely inserting the card the right way up? (gold contacts facing up)
You’re not using micro-SD cards in an adapter?

Yup 100% inserting with gold contacts facing up. I have tried 4 different SD cards (3 32b ones and 1 16gb one). I also tried a microSD card in an adapter out of desperation, but this was after all the regular SD cards didn’t work.

Was the SD card working ok before you attempted the update?

Yes all sd cards work fine on other devices, in fact one I bought brand new to try specifically for this. I have another new one coming tomorrow that people have mentioned having success with.

The new card came (SanDisk Extreme 16 GB) and it also did not work. Same three lines appear and the kordbot does nothing more.

I’m at the point where I highlight doubt it’s the SD card. I’e tried 6 cards at this point, formatted on the Mac, formatted on the PC, formatted as it comes brand new. I’ve tried redownloading the UPF file in case my download was corrupted. I’ve also tried running the boot loader update a few times to the kordbort.

What can I do at this point? My Kordbot is bricked.