First steps - issues with USB keyboard and Pan


My s2400 just landed and I just put together my first kit and starting to get to know the controls. A couple of quick questions …

  • I’m using an Apple wired USB keyboard and it doesn’t seem to work with naming kits, projects, etc. Maybe it’s just an Apple thing but is there anything else I should look out for?
  • In putting together my first pattern/kit, track 8 doesn’t seem to respond to Pan. Is there a track setting that I might have fat fingered that could affect this?

Thanks in advance for the help!

OK, so I resolved the Pan issue … there’s only 8 outputs and that’s the track setting I overlooked. The numbers on the Pan screen are the outputs … duh :wink:

I am assuming that you are speaking of a qwerty keyboard and not midi :slight_smile:

I use a HyperX Alloy TKL wired keyboard just fine with the S2400. I have to guess that the issue is an Apple thing, but I can’t say for sure since I’ve never tried one.

1 Like

Just got a Amazon Basics low-profile wired keyboard and it doesn’t work either … doesn’t even seem to power on.

That seems strange to me. That HyperX I mentioned is a full RGB keyboard and it lights up and works fine. Have you opened a support request with the guys yet? I don’t know of anything that should stop it from working, nor do I recall having to enable anything in the settings. You are plugging it directly into the USB Host port correct? No hub or anything else?

Yep, plugging it straight into USB Host. The USB port does seem to be working though. When I plug in an Aturia Keystep that seems to power up just fine.

I am going to try one more keyboard that explicitly states Mac or Windows to see if that does the trick. If not, then I’ll file a support ticket.

I can confirm I couldn’t get my older (circa 2010) Apple keyboard to work

1 Like

Admittedly I know very little about keyboards but could it be an issue due to ANSI vs ISO keyboard standards?

I am in the US just to put that out there. Not sure where @pdicorpo is, but you are right, there could be some issue with different standards.

I’ve tried 5 different keyboards at this point and still no luck. One of them is a a compact version of the HyperX Alloy. @merk is the port on the actual HyperX keyboard USB-C or is it something else?

I did file a support ticket with Isla but no word back.

UK here and keyboard works fine. Sure you’re on the latest firmware? Wasn’t keyboard support added in the most recent one from like a year ago?

Forgot to mention mine’s not an apple one though. Just saying keyboard layout doesn’t matter

@kiddles I’m on Feb 24 2022

Hmm yeah I might be out of ideas then haha

Hey pdicorpo. Yes my HyperX has USB-C on the keyboard itself. Sorry that you are having such a problem, I know it sucks. I don’t know what else to tell you to try.

I just tried my Keychron keyboard which can be wireless over bluetooth, or wired. The bluetooth adapter doesn’t seem to work in the S2400’s USB port, but it works instantly wired. This keyboard has a switch for being used on Windows or Mac, and it works fine on the S2400 on either mode. The USB port on the keyboard is USB-C.

I also just tried with an old regular wired USB keyboard and that worked fine too. If you’ve tried 5 different keyboard now and no luck I’d have to guess you have a problem with your USB port.

1 Like