Firmware update hangs, emergency update also hangs

Just tried to update from the previous firmware my machine came with to the new one. Did it via USB MSC. It sat for a good 20 minutes on the update screen, so I thought that can’t be right. Switched it off and tried out the emergency update procedure for if you were to lose power during updating. Forum says it will appear dead for a couple of minutes while updating. It’s been at least 20 minutes again and still dead.

Not sure if I can switch off during this and try again with another SD card, or if switching off now will brick the machine permanently. Getting ready to leave for work right now, so it the advice is to leave it for hours and see what happens, that will work for me.

I managed to resolve this, but only in getting back to the previous firmware.

Had a few failed attempts at turning it off and on again with the same card and same .upf file. Tried the previous firmware.upf also nothing.

Then I tried another card which was formatted to NTFS, not FAT32 like the other card (which was always happy to load and save samples and projects to though).

Putting that card in with the .upf named new firmware file, the machine turned on instantly and functioned normally with no sitting in a dead state like the emergency firmware update instructions said it would.

But it seems that card just isn’t recognised and the machine happily booted the old firmware I guess it still had in memory without trying to do anything else.

Not sure how to safely go about updating to the new firmware, but I’m happy the machine definitely isn’t dead.

EDIT: Tried again with the second card, formatted in the S2400 to appear as normal. Instead of USB mode, I took the card out and put it in the computer to copy the file. Result was the same as the first time, hanging on the updating firmware screen for half an hour. Switching off and on with no card loads old firmware as normal. Putting SD card in PC shows the firmware file is now called S2400_forced.upf so the machine seems to know it failed the update and titled it that to do a forced update on reboot. Booting with that card gives dead mode it never recovers from, same as before. No card restart, old firmware same as before.

What’s going on here? Should I just wait for the next firmware update and hope that one cooperates?

Good News, Afferbeck!

Rob Orr, saved the day in my case.
The power cables were touching the communication ribbon which was interfering with the communication between the two boards.
See pics:

Manipulating the power cables away from the ribbon solved the issue.

Rob, thank you!

3 Likes

Ha so it actually was a physical issue. Glad you got it sorted I know that had to be frustrating. Rob is the man… he jumps on these things really quickly.

3 Likes

True! Very good support.

@roborr is the hardware whisperer

2 Likes

Thanks, otobot! I would never have thought to check this. Had to dig around to find a torx bit to get the side off, and yep, all my power cables were touching the ribbon. Moved them away and tried the update, completed in a minute or two.

A lot of frustration for such a small thing. Hopefully not too many more people run into this, but searching should find this thread to get it sorted.

3 Likes

Just did the update, no problems here. 64Gb SanDISK card, copied the upd file from a Windows computer onto the card, booted the S2400, recognized it, updated it, all clean.

FWIW, I’ve noticed with other gear that uses SD cards that if I copy the update file(s) from a Mac, sometimes the extra crap that a Mac will write to the disk confuses the hardware during the update process. Not saying that the S2400 has that issue, but just mentioning it as another possible variable.

1 Like

When you’ve put the firmware update on 1500+ machines you start to get an idea of what the quirks are pretty quick.

Glad you all got sorted :relaxed::+1:

5 Likes

Hi, I also had the issue of the FW update hanging. I moved the power cables and it worked!
So, is this something that could re-occur if/when the power cables move? Should I zip tie them out of the way?
Cheers!

always format your card first in the machine to rule out any format issues.

Worked for me too!

Note to say I had a problem with the 20220224_082026 update (was on 20211001_080630).
Copied the firmware onto the SD card, inserted back into the machine, powered on, and confirmed the update dialog – unit hung on “Updating Firmware” screen for over 30 mins.
Powered the unit off, checked the SD card – the update file had been renamed to “SP2400_forced.upf”. Deleted the “SP2400_forced.upf” file, recopied 20220224_082026 firmware, changed firmware extension to “.upf”, reinserted the card, powered on. Update successfully completed after a couple of minutes.