Crashes after update for the first time

Hello im new to the forum ive owned my s2400 for about 2 years now and decided to update for the first time last night to maybe fix minor bugs after doing so my s2400 has been even worse ive downloaded and installed the latest firmware and have tried both methods via usb and sd card and cleared everything from sd card does anyone have a fix for this issue ?

Could you be a little more specific? when you say “even worse” what do you mean? You mention crashing in the title of your thread. What is happening when it crashes? Is the firmware successfully updating and then it crashes while using it? Or is it crashing the middle of the update? Any details you can give might help.


The bahvior after the update is while i am playing a pattern or recording a sample or even searching for a sample the s2400 freezes randomly and cannot work on it the way i was able to in the previous firmware

I just updated it again and the sound will turn off after about 5 seconds

I would suggest backing up the files on your SD card and reformatting the card in the 2400, if you haven’t already.

Yes i thought the same i have already tried this multiple times unfortunately with no luck i am at a loss i love this machine but after the update it has been too buggy to work with i wonder if i can download the original firmware

Hmm that’s a bummer. I think it’s probably time to open up a support ticket with Isla Instruments on the main website. I’m sure they’ll get you up and running again one way or another. Let us know how you get on!

Good luck!

1 Like

Have you tried a different SD card as well?

Yeah that was my next move but it was working ok with previous firmware i just opened a ticket

Thanks for all the help much appreciated

1 Like

Just tried a new sd card with 200mbs speed but still no luck

Did you start with an empty card or did you copy your files from the previous card?

1 Like

I did both i backed up data from the card to a hd then emptied the card and started over with a blank card it didnt work any better then i even went and bought a faster sd card 200mbs and tried that with no luck the sound still cuts out then the machine freezes i wonder if i can just download the original firmware it came with but i cant seem to find a download link older than april 2023

Sounds like you’ve tried all the troubleshooting options, it’s probably time to open a support ticket if you haven’t already. Sorry you’re having trouble but I’m sure Isla will help you sort it all out

Yes i believe i did i opened a support ticket i hope they get back to me sooner than later thanks for the help i appreciate it

1 Like