Assigned sample name corruption (hieroglyphics)?

Ok let me try to explain the issue i keep running into:

  • I have an “empty project” that i load up when i start creating something new. It’s a project with one of the kit sounds (a hi hat) assigned to 16 pads (2 banks). All the track settings are the way i want them, that’s why i use this “empty project”.

  • I load up the project and then go into the sample screen to start sampling (phono input 1 in 26k).

  • Once i’m happy with a sample i press the save button and select save to SD card root, give the sample a name (ex: Aljar01, 02, 03, etc.), assign it to a track and save it.

  • I start trimming the sample, editing pitch, start recording patterns, whatever…

And here comes the big issue:

  • Once i go back into track settings, the sample name for that track / pad has changed to random hieroglyphics.

  • If i save the project under a new name in that state and reload it, the samples assigned to the tracks have lost their trimming parameters (they are not trimmed anymore). The recorded patterns still work, but i will have to re-trim all the samples / tracks.

To work around this issue:

  • After sampling and saving the sample, i will have to go into the track settings screen for each track, and reassign the sample before i start working with them. Doing this will display the proper sample name and the hieroglyphics are gone. I can then also save and reload the project without any issues.

This happens with two different San Disk Pro cards (16GB and 128GB) in the exact same way (using the latest firmware).

Can you post the S24 and KIT files for your empty project?

Hi Mickey,

Sure, here they are…

thanks a lot!

EmptyProject01.KIT (32.3 KB) EmptyProject01.S24 (7.9 KB)

@jibber I am still unable to reproduce this issue. If you exit sample mode right after saving and assigning the sample, without doing anything else, is the track name corrupted?

Hi Mickey,

When you load my empty project, please try the following:

  • Go into shift + sample and sample something. Then press Enter and Save.
  • Select save to SD card root, rename the sample, assign to track A1, select Save File (see attached image)
  • Exit sample screen by pressing the sample button twice.
  • Press shift + Settings, go to track settings, hit A1 to see A1 track settings, and see the hieroglyphics (see 2nd attached image).

@jibber Thanks for the very clear repro instructions.
However, I have tried a bunch of times and still have not gotten the issue.
What does the new file name look like on the SD card? Is the name Test01, or jibberish?

Strange.

When i look at the SD Card the file name is correct.

However, when i save a project in that state (as a new project, with the hieroglyphics in the track settings), then reload it, there is no more sample assigned to the pads / tracks… well, there is, the one with the hieroglyphics name, which it can’t find and load from the SD card, so the pad will not play anything when pressed, and all the trimming work is gone. It means i will have to reassign the sample and retrim it (unless i do the workaround of reassigning each sample before doing anything).

I am on the latest firmware. It happens with two brand new San Disk Pro cards (16GB and 128GB), both formatted with the S2400.

Okay. I hate to keep bugging you, but could you do a video? I just need to get to the point that I can make it happen, then it will probably take one minute to fix. What I need to see is all of your keypresses, including editing the sample name.

Sure. I’ve uploaded it to google drive here:

https://drive.google.com/file/d/1fjrnRQDlfuq0uXRQBD4hASM4l_ew-lF4/view?usp=sharing

Please note that i didn’t sample any actual sound for the video (hence it says sample is empty), but it behaves exactly the same way.

PS: I’ve also tried it without loading the empty project first. Even if i just turn the S2400 on and go directly into sampling a sound without loading anything, it behaves the same way, even if i don’t edit the sample name in the save screen… I even formatted both SD cards again on the S2400 just now, so completely empty cards, all settings as default… it does the same hieroglyphics with both cards (San Disk Extreme Pro 95MB/s 16GB and San Disk Extreme Pro 170MB/s 128GB).

EDIT: Sorry for the video being rotated 90 degrees.

1 Like

thanks Jibber.
we’ve managed to re-produce this and are working on it.

2 Likes

That’s great to hear, thanks a lot Brad (and Mickey)!

This is fixed in dev. Will be in next update.

Until then, there is a way you can avoid the issue. Save a sample to any folder that is not SD root. After that, you will not get the error, even when you do save it to the root.

2 Likes

Thank you for catching it.

This is awesome. You guys rock!

Seriously, this is some of the best product support i have ever experienced anywhere.

Thank you so much Mickey and Brad!