Unable to audition samples with pads in new update [FIXED]


Encountering an annoying issue after installing the firmware update. If I hit shift+pad to select a new sample for that pad, I am unable to tap the pad and audition the sound, it’s just blank.

Is anyone else encountering this? Kind of a crucial component to making music on this thing!

Is it possible to revert back to the an older firmware? I have a live show tomorrow and the 2400 is a central component in the setup and I need it to be working properly.

video here: Dropbox - IMG_8534.MOV - Simplify your life

Yes you can revert back to a previous version easily.

What you describe seems to be the same as the topic below btw.

Oh wow. You’re right!

Do I revert back to the previous firmware by updating the unit the same way I would any other update (by putting the file in the root folder of the SD card)?


This issue only happens on empty pads. So instead of downgrading, you could just assign a sound (any sound) to get previewing back. It’s yet another annoying workaround, but just putting it out there.


I noticed something similar and related to this. I think what I was experiencing was that in the mode where you have pressed shift+pad and you have the menu up for assigning the sample, etc., the first pad press would switch to that track and the second pad press would actually play the sample. When it happened to me, at first I thought it was a bug and then after realizing the pad would play on a second press, I thought it might be a modification to the way the assign sample (shift+pad) part works now.

Anyone else reporting the issue tried pressing the pad a second time or are you just jumping from one pad to the next to the next (one press each)???

1 Like

Yeah it is the same procedure when upgrading or downgrading as long as the firmware is not too old like one of the first versions.

By the way you can also press Enter when browsing files to preview samples while waiting for a fix.

Now you say it, I suppose it is a side-effect of that specification change.

If you look at the video I posted above, you’ll see that no matter how many times I press the pad I still can’t audition the sample

Sorry I overlooked your video when I read the post. I see what you are saying now. I’ll move this over to a bug report.

This bug is fixed in dev and will be fixed in the next release.
The short-term work around is to assign any sound to the pad, then preview will work.

1 Like

Thanks for fixing this Mickey, experiencing it too.