Snap all points to zero crossing not working

When you’re in slice multi mode and have the waveform editor open, long press F5 activates ”play only one bar” function instead of ”snap all points to zero crossing” like it says in the help menu I think this was not the case in the previous firmware.

At first I could not reproduce this behavior. But after messing with loop functionality, I understand what is root the problem: after disabling the loop this appears.


  • Open the waveform of a sample.
  • Hit shift B (enable loop).
  • Now everything functions as it should.
  • Hit shift B again (disable loop)
  • Now the longpress F5 behaves different.
1 Like

Fixed in dev.
The bug only happens when the cursor is on scroll. Short-term fix, press enter go move the cursor off of scroll.