Sampling from computer/youtube

just got mine yesterday! im a complete noob so bear with me. I have a usb connected to my pc from the 2400. what else do i need to do to record a sample from youtube for example? I’ve gone inot the input monitor and the usb audio input is on, i have monitor on the headphones, when i press play on YT, I hear the song, and in sampling mode, no signal is detected. do i need to connect audio in’s and outs as well? I thought Brad said u just need a usb cable? Anyone willing to help a noob, and brother out? thank you.
i can hear song when i press play, but cant hear it when i go into sample mode on the 2400?

In the Sample screen, you have to select USB as the source. The Input Monitor and sample in are separate items.


thank you so much! oh, i also am experimenting with some of the samples you shared!! Cheers!!

1 Like

sorry to bother you, but now when i play the song i want to sample, the sampler doesnt record. I press rec/edit, the timer comes on as 0:00:00 but doenst actually record? I know im prob missing something simple but if you dont mind ? I wont bother you again, at least fro today! lol
it did work once but halfway thru the sample, so i erased that and tried again it doesnt record? wtf? it does record if i change it back to like 24kh but at usb is doenst work. i know my unit doenst have the aug firmware update? is that the reason?

well after switching back and forth a few times, between usb and 12 bit settings, the usb sampler its working now. strange start to sampling. lets hope this isnt a recurring issue, cuz its a friggin sampler for crying out loud!! so sample already lloll

I would check your threshold settings, make sure that the signal out of youtube is as hot as possible. Ive noticed that some sites( seem to embed a player that has a low volume on purpose so it may not trip the threshold.

the levels were fine. it literally wasnt recording. the timer stayed at 0:00:00 on the 5th try it started about 10 seconds into the sample. I erased it and tried again , didnt work. So i switched the settings from USB to regular, or 12 bit, and it started recording as the timer started ticking. But not in USB., then I turned it off and on, and it worked!! I really do appreciate your time.
Thank you. Its nice having support cuz its a bit overwhelming, but Im game to figuring it all out! Super excited now that its working! Cheers.

1 Like

I’ve come across this issue myself a few times. It is easier to sample from the computer via the USB connection but I prefer to sample through the audio ports bc of this being a bit finicky.

In fact I just went to try it again and I have the same thing going on.

1 Like

@parishbishop Been chatting with @iofflight about this and trying to duplicate. If we can find a recipe will submit a bug for it. If you find a way to reliably reproduce it let us know and we can try.

ok will do. thanx again guys. great knowing theres a real communtiy here!

I was having an issue with my audio routing and so it wasn’t sending anything properly to the S2400. I’m on a mac. I had to get Loopback and set up the routing and then my USB sampling worked fine. However I do notice sampling from youtube is low volume even at the highest settings and it was hard to trigger the sampling. When I used iTunes it was fine however.

I suspect my previous glitchiness was due to audio routing via aggregate device being flakey.

ok, its bugging out again when the decibel threshold is set to -1db or any other number besides -100db. Is this a safety thing? what should the decibel settng be at? it wont record unless its at -100. I can hear the samples just fine when they are recorded at that setting . ive only done a handful so far.
Ok I see in the user manual under Threshold settings it wont start sampling under that amount. I know nothing about this. Can you guiys explain where I should keep the settings, if -100db only is a bug. Thanx.

What is the sample source on your computer? I found the threshold settings really touchy with the computer to USB. Sometimes it was way too soft and other times it really hit max quickly.

1 Like

you tube. i sampled some pulblic enemy and then some mood music from a ufo channel. i can hear them fine but there not super loud either as samples. am i supposed to set a volume level in the pc as well? Also what about the 2400 threshold settings for sampling? it wont reord unless it set at the -100db ?

I recently had the exact same problem on the TE OP-1, I think it has more to do with the quality of the upload in YouTube. Some sources would work flawlessly, and others wouldn’t even register. Not an issue on the line in, but results varied drastically over USB.

1 Like

It’s merely telling you the source is really low output and the threshold has to be at lowest setting to register the audio and trigger the sampling function. I had to do that when recording from the computer except when I used an app like iTunes. That said there is a small knob on the the back the unit that you want to turn to max but that is for the phono and line ins. It doesn’t have an affect on the USB. The USB relies solely on what the output of the computer system is. This is one reason I haven’t used it this way very often. It’s better I find to get the audio you want downloaded or captured on your computer, run it through some processing or compression and then run it into the s2400 via Line Ins. I have a lot more control that way.

I do however use the USB outs for the audio into my DAW. I tested this out extensively and found I liked it slightly better than the audio ins (which was a true shock to me as someone who isn’t a fan of USB audio in general) and it freed up 8 ins on my interface so it was a double win.

1 Like

thanx for your reply.

Each to his own and all that but… In the old samplers, much of the character was created in the A-D convertors. Using USB bypasses them completely so you may be missing out.

Only a whole year late. : )


Agreed. I actually use the USB out for the audio but for sampling I generally use as much vinyl as possible. It’s not the same coming from the tube but it’s nice to have in a pinch for sure. Especially for random dialog from B films.


I appreciate it , thx.