Issues with USB audio


I have a few issues with USB audio:

  • I don’t get any output to USB while sampling.
  • I also don’t get any output to USB while editing right after sampling (before saving).
  • But I do get output when previewing sounds on the SD card and from monitoring the analog inputs, just not while sampling.

Maybe I understood this wrong, but I was hoping, that with USB audio, I wouldn’t need to connect the S2400 to a mixer or anything and could just plug in the USB to my computer and get ALL the audio through my DAW.

I have tried every setting I could find, if I missed something, please let me know.


1 Like

First I’m assuming you’ve watched the video manual on USB audio.

What system are you on? Windows or Mac?

Have you selected USB audio in the global settings? Do you have the stereo USB channels set to first or last? This can matter when dealing with your DAW or with a mixer. If USB audio is set up as the default of Last instead of First I can’t hear it through my mixer unless my DAW is opened up and I have that channel selected for monitoring. And have you set the input monitoring to USB to active? And what do you have your monitoring channels set to for USB?

As for transferring audio back to the unit via USB this becomes harder to troubleshoot because it’s likely the lack of audio from computer to S2400 via USB and you have to troubleshoot your system not the S2400.

I have really intermittent USB sampling success unless I have the App loopback set up to route it directly to the S2400 and tell the Mac to send it there. I just have too much going on with aggregate devices in my system for it to be consistent within my system.

I‘ve tested it before, with a slightly different setup, but just to make sure, here is what I used to test it yesterday:

  • Macbook Pro running Logic Pro X
  • Apogee Duet 2 connected to USB as the output device
  • S2400 connected to USB as the input device
  • Logic project with 10 tracks mapped to the 10 inputs from the S2400
  • All tracks set to record with input monitoring enabled
  • Turntable connected to a Vestax mixer
  • Vestax mixer connected to input 1 on the S2400
  • None of the outputs on the S2400 are connected to anything (that‘s the important part, as I want all the output to go to USB)

It’s a very simple and stable setup, no aggregates or anything, just one device for input and one device for output.

As I said, when I enable analog input monitoring on the S2400 and send it to USB mix, I do get audio in my DAW, until I go into sampling mode (on the S2400).
I don‘t get any audio in sampling mode whether I‘m actually recording or not.
I also don‘t get any audio while editing the sample, before saving.
I do get audio when editing a sound that is assigned to a pad and I also do get audio when previewing a sound on the SD card.
The USB mix order doesn’t actually matter in this case, it just shifts the channel positions, as it’s supposed to.

I have also tried enabling/disabling the monitoring while sampling setting, but that didn‘t change anything. That setting doesn‘t have a send to USB option and I think that might be part of the issue.

So since all the other previewing and monitoring functions work, I assume it must be something missing in the firmware.

So to be clear you aren’t sampling via USB only sending audio out via USB. You are actually sampling using line 1 in on the back of the unit. Stupid question have you turned the input trim knob on the back of the s2400 up all the way?

Yes I am sampling from the analog inputs and I do get audio when turning on monitoring from analog inputs and send to USB mix in the monitoring settings of the S2400, so yes the input actually works and sound is coming in, it just doesn’t work once I go into sampling mode (shift + sampling on the S2400).
I do see the waves on the screen and the input level indicator on the pad LEDs while in sampling mode and it does actually record audio.
I also see the waveform in the edit/preview mode after sampling, but I also don’t get any audio here. When I then save the sound and assign it to a pad, I get audio from that pad on the appropriate channel.

The problem is really just in sampling mode and the preview/editing mode right after.

1 Like

Can you post a screenshot of the audio setup prefs- I will try to duplicate in Logic on my setup.

Okay thanks for the clarification. I’m not going to be in front of my machine for another 7 hours… but yes a screen shot would be really useful. Thanks!

Ok, so here’s the setup:

Logic Audio Preference:

Logic Track/Mixer Setup:

S2400 USB Mix Order:

S2400 Preview Sound Setting (in Browse Files):

S2400 Input Monitor Settings:

S2400 Sample Settings:

Steps to reproduce:

  • Audio interface connected to studio monitors (or similar)
  • Audio interface connected to computer
  • S2400 connected to computer via USB
  • Audio source (i.e. Turntable) connected to input 1 of S2400
  • The S2400 should only have 3 cables connected: power, USB going to the computer and the audio source going in to input 1
  • S2400 powered on with settings from above, left on default screen
  • Logic session opened and setup like above
  • Make sure, all tracks are armed (R) and have input monitoring enabled (I)
  • Now start the audio source and you should see audio coming in to Logic through the stereo mix, all good up to here
  • Now, without turning off the audio source, hit shift + sample on the S2400, now no audio is coming in to Logic anymore, but you should see the waves on the S2400 screen
  • Now hit record, there is still no audio coming in to Logic, but the waves are still showing on the S2400 screen
  • Now hit record again, to stop the recording and hit enter, the enter the preview/editing screen
  • Now you should see the waveform of the sampled audio
  • You can now turn off the audio source
  • Now hit play, there is no audio coming in to Logic, but you should see the cursor movin on the S2400 screen, indicating it is playing
  • Now hit shift + save, choose a pad to assign the sound to and save
  • Now when you hit the pad, there will again be audio coming in to Logic on the selected channel of that pad

This is as detailed as I can explain it, hope it helps reproducing the issue :wink:.

Thanks for looking into it.

1 Like

Thanks for the detailed post. I will set up and let you know what I see.

1 Like

Thanks that is excellent!

So the good news @steveomentals is I can duplicate the behavior you see. At first it threw me off too, but the issue is that is expected behavior.

Since the audio engine runs at 48khz the USB audio engine is muted for 12/26khz sampling. Once you save the file and assign it to a track you will hear the output. If you sample at 48khz you will be able to audition new samples after capturing them. After you edit and save them you can use the units resample function to downgrade them to 12/26 which will work over USB. The limitation is with newly recorded samples.


@StupidAmericanPig Ok, I understand that this is normal during sampling, I can work around that.

But I don’t really understand, why it shouldn’t work while auditioning the sample before saving, when it does work when playing it after saving. The only difference I can think of, is that one is played from memory and the other is streamed from the SD, but both have the same bit-/samplerate and both play through the 16bit/48khz output.

I’m not privy to the details but it’s something to do with how the audio engine is implemented. @av500 would be able to give you the full scoop. I think it’s something that is feature request worthy though.

when the sampling mode is 26K, the system runs at 26k, thus also when doing preview_after_sample, there is no USB audio sent back during that time


So as I understand, as soon as you enter sample mode, the engine is switched to 26k (if selected) and because USB audio is 48k, there is no output to USB. Ok, kind fo get that.

But technically, the system could be switched back to 48k when auditioning the sound, since the sound is then in memory and could be played back through the 48k output, just as a 26k sample that has been saved and assigned to a pad and is streamed from the SD.

Or am I completely wrong here?