Run/Stop button not working after firmware update

Not sure if anyone else has experienced this after today’s update, but for some reason my run/stop button is no longer functioning after installing.

Forgive me if I missed something in the changelog about its behavior changing, but I can’t imagine that would be changed as it’s pretty core functionality.

Have tried reinstalling firmware, multiple reboots, etc, but to no avail.

If you hit shift+run stop does it work? If so I suspect you are in external clock mode.


there ya go. thx.


@iamkory This happened to me - make sure the sync is set to internal and not to another sync device


I had the same issue 10 minutes ago…Then i installed the latest firmware and is now fixed

1 Like

yeah, didn’t realize that carried over on firmware updates. appreciate it.

The firmware update does not erase the global settings file (S2400.SET)

Ok, I’m glad I saw this because the same happened to me and I was about to slam my S2400 on the desk like the guy in the FB feed. J/K! LOL!!
Now it works. Thanks.

i would suggest having a little blinking clock icon somewhere on screen if run/stop is pressed and no clock is recieved. or blink the button, or blink the button at lower brightness or something.

In the next firmware update, the Sync button blinks when Run is pressed to remind you that the clock source is not internal.