Pattern Copy corrupting patterns

(I am on July-15, 2021 Firmware)

When I attempt to copy a pattern (1) to a new pattern (2) either one or both patterns get corrupted in the process by omitting sequencing steps across various tracks. Playback is also affected on either one of both patterns - in one instance when pressing play, the sequencer would run once through the entire pattern without playing any of the step, except for the last steps on one track in the last bar.

Please post your project file (.S24) here. Thanks.

Please find corrupted Project file attached. I attempted to copy patter 1 to Pattern 2 and Pattern 1 is now playing only the last notes in the last measure although all the step by track show up in the sequencer in step mode.
TECHNO_011.S24 (11.8 KB)

I can see that they are both corrupt (looking into the bytes of the patterns).
I do not understand how pattern 1 got that way. or pattern 2 for that matter. I am able to copy pattern 1 to an empty pattern, and the copy comes out identical.
Was pattern 1 working before the copy? If so, did you save a copy of it while it was working?

I think I’ve just had a similar bug so let me post in this topic.

I think the main problem is doing something that was not intended to but in the following cases I had 2 issues:

-Erase a whole pattern and immediately regret it. There is no UNDO after a whole pattern erase so what I did is Copy, change source to SD card to try to reload (copy) the pattern and got an error.
(screenshots below)

-When there is no error and the reload works, it creates another type of bug. For example 1/4 of the pattern plays normally and the remaining part plays pitched down.

I’ve saved it as a different project so I can send it to you in private if it can help checking something inside.

@tnkz76 Please send me the project. I only need the S24 file, not the KIT or WAVs.

Here is the file.
In this file, I erased the whole sequence 3, then reloaded it from the SD card.
With the WAV file it seems to play fine on the first beat and then it seems to be pitched down.

Project001.S24 (10.7 KB)

I erased pattern 3 and reloaded it from the SD card. It is identical before and after. (I can see the actual data bytes of the pattern.)

I can see that it is pitched down in the pattern, so it makes sense that it sounds that way.

My bad sorry for the lack of clear explanations.
If it is possible to do, please compare with the file on this post.

The file on this topic is the file I saved after I got the error on pattern 4. (screenshots above)
I tried to see if I could reproduce the bug on pattern 3. I couldn’t. It reloaded pattern 3 on pattern 3 “sucessfully”. Nevertheless it seems to have corrupt the pattern.

Project001.S24 is the file saved separately to keep a record about the issue on pattern 3.
KBANLAL.S24 is how it sounded before the issue.

By the way I’ve tried to create a 100% reproducible step by step and failed. The issue on pattern 4 might have influenced the issue on pattern 3. I don’t know sorry.
Hard to reproduce unfortunately :frowning: KBANLAL.S24 (10.9 KB)

There is a one byte difference between pattern 3 in kbanlal and pattern 3 in project001. That accounts for the pitch change. I don’t know why it was not copied correctly from the SD card. Was a pattern running when you did the copy?

I don’t remember sorry.
Doing it right now while the sequencer is running doesn’t reproduce the issue.
Otherwise I always use fader lock and transpose instead of pitch.
I ll pay attention in the future if I have a similar issue.

Doing any SD card access while the audio engine is reading samples from the SD card is problematic. That is why you cannot save a kit or project while a pattern is running. We will have to do the same for copying a pattern from the card.