Newbie - Select knob doesnt scroll?

Hi all,

Just got my S24, First thing I am doing is going through the Alex Ball video manual.

On video 1 he tells you how to format your SD card (1:43 of video) He says, press SHIFT and SETTING " And scroll down by using either the encoder or the arrow keys"

Well, my encoder doesn’t do anything. Not really much I can do wrong. Its right at the start of his video and he only pressed two keys and the encoder. Mine doesn’t work the same.

Is this cause for concern? Maybe an internal setting that I cannot find?

(Running the latest firmware)

Are you saying the encoder isn’t scrolling when you rotate it? Or that it doesn’t enter things when you press down on it? Or both? Just making sure that you’re not trying to do both at the same time.


If I push down its the same and pressing enter as Id expect. But it will not scroll. The knob moves, you can feel the increments of the physical controller etc but the software does not respond.

I just bought this second hand on Ebay. The seller listed it as unused and I have to be honest I believe him. It was packaged with all the original packaging and such.

I don’t believe he has tried to pull a fast one because, well you cant on Ebay. They just refund you (me in this case) and take it up with seller (him). Also the Select knob has to be the most used control on the device. Not like its gonna be hidden a few weeks so he may get away with it.

No I dont suspect fowl play I feel its been like this since new. Sadly the warranty will have well passed by now. Not wanting to return to him as I really like it.

I feel its defiantly broken. I thought Isla spent alot on build quality. It does feel solid mind.

Well you can’t really know a device’s history with eBay. If the encoder scrolling functionality isn’t working properly and the seller advertised the unit as working in good condition, I would try to return it and get a refund if possible.

1 Like

Reinstall the firmware before you return it. He may have bricked the encoder and didnt know this.


@notanumb3r Yeah but I really want one of these. I can get around it with the cursor keys so far.

@Peter_C Ive updated the firmware. It was like this with the older one also. I will try and reinstall though. Cant hurt

1 Like

No, reinstalling firmware makes no diff sadly.

So there is no OS stetting where you can disable the Select knob?

ugggggg Looks like I am one of many.

Thread entitled Encoder issue

This really isnt a good intro to Isla at all. The build quality that is constantly mentioned is one of the things that attracted me. Ive never ever had an issue with my MPC 2500 and its like 15 years old.

1 Like

Sooooo I try and open a ticket. I go to Support

and I see text that says …

So where is the form to fill out? Don’t say the web site is broken too? Really?

1 Like

Hmm, I see the form on my browser (iPhone Safari). Maybe try a different browser?

Ok mate will do. Thanks Im on Firefox PC so nothing too obscure.

Do you have Adblock or any other similar extension for Firefox? I just tried to open a ticket and the page with a form opened instantly on Firefox, Chrome, and that horrible Edge thing. It could be Adblock.
Sorry to hear about your issues dude, but to be honest, eBay or not eBay, if you buy something second hand, you have absolutely no idea of its history, and whether people seem genuine or not, there is no definitive way to tell. And you can’t really blame the build quality of a manufacturer if you don’t know the history of the unit. I would send it back dude. Save your money a bit longer and get a new unit. That extra bit of money will buy you peace of mind. That is priceless IMO

1 Like

Hi mate, Just tried on duck duck go from my android and exactly the same no form thing there also. This is getting tiresome.

Ive been on Ebay for over 20 years. But making music since the Akai and the Atari were king in the early late 80s. Yes I’m old.

I can’t guarantee this was no broken before but my spider sence says the Ebay seller is legit.

Reasons being,

1 - you cannot loose on Ebay. Ebay and Paypal have your back 100%. I raise a claim and they literally take the money off the seller and at least put it on hold. So there is no way the seller could win and he’s a guy who has many hundred positive feedbacks so will know this.

2 - The item was sold as unused and its packaging backed this 100%. Also there is not a mark on anything. It is prestein condition. As you would expect from an unused item.

3 - The seller as said is not new to Ebay with hundreds of positive only feedbacks. The Select wheel /knob/pot is a control you use every few seconds when using the machine. Its not something that could be hidden. Any buyer will find this fault within the first 1 minute of turning it on. So why bother going through the returns procedure.

4 - Considering the fact that in the thread I linked too, hundreds of others had the problem that they got their machine new from Isla and there Select control was buggered too, I think the most likely outcome is this was like this when new. And the buyer really did get this and never use it.

Thanks for your reply.

Can any kind soul please tell me exactly what browser I have to use and exactly what style of phone or computer Isla require for me to be able to open a ticket? Ive tried my phone and laptop now so gonna have to lend a friends what in itself is crazy!

Sorry for the attitude but this is a terrible start. Had MPCs for decades and not a hitch.

1 Like

As I said dude, I can open a ticket using Chrome, Firefox, and Edge on my phone and my computer, so I have no idea what your issue is. Did you check if you had an adblocker? You didn’t say. This can sometimes affect sites opening pages completely.
Yes, I saw the link to people with a similar issue although I count less than ten different people with the issue, not hundreds, so maybe I am missing something somewhere?
Oh and you’re not old. I started making beats in the early 80s and I don’t call myself old lol. There are a lot of us about :slight_smile:

1 Like

Yeah I use ad blockers. I dont want adds. Surely that shouldn’t affect a support ticket.

I mean I can reply on this forum and make threads. Its surely the same thing.

Ha, just cos we are many doesn’t make us not old. Wouldn’t want to be young these days bud. Im glad I experienced real life before the internet.

Annoying as it is, adblockers can affect things like that, regardless of being able to post on the forum. God knows what goes on behind the scenes with adblockers. Needless to say, on more than one occasion, I have had an issue that has me pulling my hair out. Turned off the adblocker for that particular page. Worked instantly. So I just wondered if that may be your issue. Have you by any chance considered having a look inside the unit, as one of the guys did in that thread you linked? If your warranty is gone and you definitely want to keep it, you don’t have anything to lose really (as in you can’t void a warranty that does not exist). It might be the same issue. Anyway, good luck. I hope you at least manage to open a ticket. Isla are usually very responsive. Alternatively, send them a direct email.

1 Like

Hi Conan,

Thanks for all the advice and idea. They are greatly appreciated.

Hmmm, yeah well, that’s the thing. I open it up and the Ebay Seller would have every right to not take a return. And I wouldn’t blame him. Worse Imaging I brick the thing.

I think it comes down to see if Isla will do something. Id guess send me the part but I would need a tech to fit it. I have one but he’s not local. So its postage there and back. And time he takes, usually a month turn around. Saying it out loud like that, its all such a hassle

If they won’t Ill return it to the seller, who has said he will take the retun. He’s been spot on. TBH I feel for him.

EDIT - Just tried turning off add cookie blockers. Nothing changes. Like I say my phone used a totally different browser.


Edit 3:- Same again! Encoder issue - #23 by fac

From personal experience, I suggest you sent the unit to Isla for repair. Try to open an account/ticket using a computer, not a phone. If you don’t have a computer go to a library or a friends house. Plenty of browsers to choose. I wouldn’t even take it to a “tech”. If he’s screws up, you’ll end up having to send it to Isla anyways. By then you’ve wasted time and money.

Good luck.


Thanks mate.

My tech doesn’t screw up. Thats why he’s my tech. I trust him with items worth way more than my Isla. 808/909/101 Junos and on and on. So im certain he can do this. I would screw up but a good tech is a pro.

Sending to Isla an issue in itself as even thought half the videos i see coming from Isla are all from English men, there based in the US. Im an English man actually in England. As mad as that sounds haha

If you have a tech, that might be faster and cheaper anyway. but for future reference, Isla does have a tech in the UK Jazzcats Akai Parts & Repairs (@thejazzcat) • Instagram photos and videos

Also, there hasn’t been hundreds of people with this problem. Maybe a dozen but not hundreds.

Hope you’re able to get this sorted out soon! Welcome to the forum!