Internal (& extenral) Sync/playback issues with my unit

Hi Rob,

I have ran into a weird issue with my unit. I am getting issues with the internal clock, or perhaps it’s the sequencer playback that doesn’t work properly. Samples are not always triggered from the Sequencer in time (actually I more often get false triggers than correct ones) and sometimes samples aren’t triggered at all.

I have my S2400 connected to an iMAC with channels going out separately to 8 interface inputs and from there to my host DAW Ableton. I’m using the internal S2400 sequencer. At first I was using Ableton to sync the S2400 via USB. However, I was running into Jitter (short spikes of the clock jumping, and not triggering samples properly in case jitter is the wrong term) and ultimately Ableton and the S2400 drifting out of sync. I posted a video of this on facebook happy to share here again.

I spent the whole day trying to get to the bottom of these issues. I tried using a pulse recorded from a eurorack system sent out through an audio output of my interface to the S2400 clock in. This was a tip I received from a friend. It improved the stability of playback slightly (in the sense of sample trigger with correct timing) but not fully and neither resolve them going out of sync.

Upon Brad’s request I then tried to use the S2400 as a clock source, and have Ableton follow it. That also didn’t resolve the miss-triggering nor the going out of Sync. So I set the S2400 to internal clock, and listened from the headphone output. I was still getting the same behavior.

I recorded a few passes of the full loop (stopping and starting in-between) and after that a few passes of just the beginning of my Loop being re-triggered (by pressing start/stop). It is clearly audible that there are timing issues, and more so, that the playback is different every time. It’s almost as if there’s a stability issue with my internal clock, or the sequencer. Again, this is from the internal clock and I was checking with my headphones on the S2400 headphone out to make sure this is not a weird recording artifact or anything - and can confirm that it sounds exactly like this coming out of my unit. Unfortunately, that makes it pretty useless as a production tool for now :frowning:

I’ll attach the master out recording and the zipped up project for you. Let me know if the individual channels can be of help. Hope we can fix this! (Or perhaps I am making a stupid mistake somewhere else?)

All the best,

I couldn’t attach the Zipped project nor the wav/mp3 of my master out. I made the files available here for the next 7 days. Happy to reupload if need be.

Might be good to mention that I was on the firmware 2021-11-22, but also tried 2021-10-09.

I took a look at your project. I have a theory:

You’re using one sample that is 10Mb in size. Samples over 2Mb are streamed directly from the SD card. I suspect that, for whatever reason, your SD card is struggling to deliver the data. To confirm, try soloing Track2 (the long sample) and see if you still hear the timing problems. Or, delete that track (just for the experiment) and see if the timing improves (all the other samples will play from RAM).

If you’ve got another SD card you can try, transfer the project over and see if you get the same result. Fwiw, the project seemed to play fine here.

1 Like

Thanks! That was very quick. I will experiment with this asap, and also grab a new SD card. Will report back!

Hey there,

I’ve gotten my hands on a SanDisk 32GB SDHC Extreme UHS-I U3 90MB/s V30 card for experimenting purposes. Unfortunately, I can’t get this card to work. I formatted it in the S2400, which changes its name to “S2400” when read by the computer. However, the S2400 reads a weird string of symbols as its name. Neither the computer nor the S2400 show that there is anything on the card.

I manually created a “PROJECTS” folder and dropped the files from my SD on there via my computer (maybe there is already something special to do here that I am missing? Manual doesn’t specify anything). Unfortunately, the S2400 keeps on just showing this long, weird string of symbols and says “No Files Found”. Anything I am doing wrong here, or is this an SD card that can’t be used with it? Borrowed it from a friend who’s a photographer. I’m not so knowledgeable about SD’s and maybe that is the issue.

maybe I got to get a different SD - recommendations?

Thank you so much for looking into it further!

what happens when you go up a folder level?

Hey Mickey,

thanks for chiming in. Unfortunately, just more gibberish. Both folders don’t hold any content, and I don’t see them on pc.

Try a Lexar or Samsung Evo.

I’ve also just noticed that there is no confirmation for successfully formatting the SD card. Is there meant to be some kind of on-screen feedback? Maybe it’s just the formatting going wrong with this one.

I’ve just gotten my hands on a Samsung EVO. A few interesting things happened.

  1. After formatting the same gibberish appeared, except this time the folder on the SD card is called “Z,”. No other folders on the card. However, this time “Z,” could be read on my imac, where the card was also called “S2400”.

  1. On this card, I was actually able to create a folder called “PROJECTS” on my imac (still confused that the S2400 formatting doesn’t create this itself), and insert the project I was having issues with - this could also be read by the S2400.

  2. The sync/playback issue did not occur as of now. I’ll test it further this evening (with the whole setup) and update here.

  3. The issues I had originally mentioned in the Facebook post still exist (most notably using shift+A for modifying of multi-mode envelope A2-2 also modifies A2-2 multi-mode filter settings, modifying multi-mode envelope A2-7 also modifies the A2-7 multi-mode pitch fader setting for that pad) I will create a further bug report for this.

Is there anything I can do to check whether the gibberish is an issue with my unit?

As of right now I’ve had someone else with the same issue of their card becoming unreadable it was a San Disk ultra. The SD card not being read is one thing but all the folders being altered is another level.

And yes I’ve had some gibberish, usually just one folder with nothing in it that I’m able to delete in MSC mode. So I wouldn’t worry about your unit being the only one showing that particular behavior.

Try reinstalling your firmware again but with the new card.

Thanks for the info, good to know that it isn’t my machine that’s going crazy. Not the most disruptive bug, I recon - but distracting and confusing nonetheless.

Update on the general sync issues:

I have by now also managed to make the Project work on the SanDisk 32GB SDHC Extreme. I get stable sync via USB, and the reported main issue in this thread of Sync/playback issues seem to be resolved. Looks like it was the SD card I initially used after all.

All other bugs reported here have been moved to bug report 5911 for unwanted changes of other parameters accompanying modification of multimode envelopes A2-2 and A2-7 in this project, & 5932 for the SD card gibberish name and folders

5911: Modifying Multi-Mode envelopes causes changes in other, unrelated parameters (Filter, Pitch)

5932: Gibberish SD card name & folders after formatting