Filter & Envelope setting are ignored when entering multi mode

This only applies to the filter and envelope 2 (envelope 1 works as expected)

EDIT: The problem is also the same with envelope 1 if you use that for pitch or filter mod and use the classic envelope for volume. If classic volume envelope is not activated envelope 1 works as expected.

If you set a filter value or set the envelope 2 the settings are ignored when you go to pitch or level multi mode.

This happens regardless of multi mode sync activated or not(even if this should have nothing to do with the multi mode sync function).

I would expect the filter and envelope 2 to work the same way as level, pitch & envelope 1. If you set a pitch or level for a sample that value is still there when entering envelope multi mode. But when you set the envelope 2 or filter they no longer apply if you go to pitch or level multi mode.

And I also noticed that the only multi mode the filter setting actually applies to is the envelope multi mode.

Yes, this is expected behaviour. Filter Multi-Mode is automatically enabled when you go into Level, Pitch or Env Fader Multi-Mode. This means that any filter settings you made in normal Pad mode are lost and you now have 8x default filter settings. There is still envelope assigned to filter, but it’s likely you just can’t hear it because the filter is fully open already.

It’s not ideal, and there is some discussion going on within the team as to how it could be improved, but nothing concrete yet. In the meantime, in your example above try this:

  • go into multi-mode Level or Pitch (your filter settings will be temporarily lost due to Filter multi-mode)
  • record your pads into the pattern
  • after record, exit Level/Pitch Multi mode
  • enable Filter Override (B button) (you should now hear your filter/env settings again)
  • Shift-B and Modify Pattern

It’s a long workaround, but it will get you where you want to go I think.


Oh ok no I see the problem, and after doing some more testing you’re correct. If I only use the envelope 2 for pitch modulation it’s still there when going to the other multi modes, it’s only the filter causing the problem.

So basically if there was an option for the filter not to automatically apply to each pad in pitch & level multi mode that would solve the whole problem.

I first noticed this behavior when playing with the single cycle waveform included in factory content. I took a waveform and sculpted it to a nice synth sound with filter modulation from envelope 2. Then when going to pitch multi mode to play notes the filter envelope is ignored (for the reason you’re telling me here) making it sound like a harsh looped waveform again.

This behavior makes the single cycle waveforms pretty much unusable since you have to manually set the filter envelope for every single pad in pitch multi mode which can take forever.

Also you can’t do stuff like set a filter value to a hihat sample, go to level multi mode and record that filtered hihat with different levels, you’ll have to set the filter individually for all pads again in the multi. Or just set a filter value to a piano chord and go into pitch multi mode and play the sample with the set filter value in different pitches.

But you’re saying the team is aware of this problem and are working on a solution?

it’d be nice if there was a parameter page copy - that would possibly remove this issue, make the edits on the main page then copy parameters, enter multi and paste to the pads you desire

the obvious fix would seem to be for any edits made to a pad before entering multi are duplicated to each multi but in reality this is wrought with danger , 2 seconds thinking about this and you arrive at a few headscratchers and i imagine a lot of potential pitfalls for mickey et al so i doubt this obvious way is actually a way at all

What are the dangers you see with that solution?

Another solution would be for the filter NOT to automatically switch to multi mode when going to pitch/level multi and behave like the level or pitch modes. Or make it an option so the current behavior is still there when needed. You can set a level/pitch for the pad and go to envelope multimode and play them with the set level/pitch, if the filter optionally also worked like that it would solve the problem I quess?

Like the idea of parameter copy but for other reasons than solving this problem. Would be more fluid if you didn’t have to paste settings on every multi to achieve this.

Yes. Although it can be difficult when a system has been in place this long. Changing it could break other things, so it has to be carefully considered. We are aware of it as a shortcoming. I’d personally like to see a solution, but Mickey and the team has to find the right one first.


I wouldn’t call it a shortcoming. Multi Mode filter settings are a powerful feature. I understand that not everyone wants that feature, and I agree that a switch to turn it off is a good idea.


Is it possible to have both? So if you have any envelope modulating filter, when you go to multi level/pitch mode you are just adding or subtracting filter cutoff, just like adjusting cutoff when you leave the envelope page. I hope that makes sense how I explained it

Then if you want how it works now, just don’t have filter to env.

1 Like

Yes don’t get me wrong mickey, the filter multi mode is a great feature and I use it all the time.

But there’s some scenarios when it would be really handy to be able to turn it of as mentioned above. Then you could sculpt some nice filter envelopes and play the sounds chromatically in an instant, without having to set up the envelope for each pad.

1 Like