Envelope duration doesn't change when assigning new sample (SOLVED)


  • record a few notes with a short sample (like a snare)
  • assign a new longer sample to the pad (like a cymbal)

The cymbal will preview ok when you are sample browsing but when you commit the cymbal sample to the track it will play too short as if it’s been gated and you’re only playing a bit of it.

What seems to be happening is that the envelope duration remains from the short snare, so only part of the cymbal plays. But I want my cymbal to play as a full length one-shot.

There appears to be no way to force the envelope to be the duration of the new (cymbal) sample - because envelopes can’t be overwritten (as far as I can tell)

So I’m stuck.

It seems desirable for new assigned samples to take on the ENV parameters of the sample they replace (eg attack & release) but not duration.

@Mickey is there a workaround here? Seems to be a bug.

If you press back button + the pad to reset all settings, does that solve the problem?

that’s a good tip thanks (handy!), but doesn’t work for this issue.

Events in the sequencer have a sample-start and a sample-end value. The sequencer uses the sample length to determine the endpoint of the event (unless you record in gate mode).

Lots of users don’t realize this and think that you only can use 8 (9) slices per sample (in multi mode slice). When actually it is limitless…

So, your specific use case can (probably) only be resolved by entering step edit mode, hitting F2 and then increase the endpoints of all events your have recorded… ofcourse you also can record the notes again, but my guess that is not what you are looking for.

Thanks that explains the situation very well.

I don’t want to re-record the notes as I want to retain the position/pitch/level that is already recorded, I just want to replace the sample but without the sample-start/end points remaining from the previous sample. Actually when you preview a sample it doesn’t reference the recorded sample start/end points, it’s only when you commit the sample to the track that it becomes truncated.

SO what could be a good solution here would be to have some kind of preference > eg ‘assigning new sample overrides previous sample length’ OR 'reset sample length’

1 Like

Can you solve the problem by activating loop/slice override mode and adjust it there?

Or envelope override mode and tweak the setting there to make it work?

loop/slice override , them modify pattern works! thanks! :slight_smile:

if you press B while in loop/slice you see the new sample playing to the endpoint of the previous sample, so the override works to solve this.

Now i’m clear what’s actually happening i’m happy to think of this as a ‘feature quirk’ rather than a bug. thanks for helping.