Digital Audio Glitching with USB Audio

I am having a problem with digital audio glitches + static intermittently when using the USB audio output. It sounds similar to when the sample buffer is too low and my DAW overloads but happens regardless of whatever I change (DAW buffer, drift correction, USB port, etc). I’ve also tried while running Ableton on multiple Macs + had the same issue. Seems to be worse when I’m using the 2400 in conjunction with another interface as an aggregate device. I know the USB audio is new and issues should be expected- I just wanted to post as I hadn’t seen the issue in glitch reports. Thx!

Have you changed your sample rate in aggregate devices and in Ableton to 48K?

1 Like

Yes always 48k!

But that’s a good point I don’t know if it’s 48k in aggregate devices. Will check when I’m home!

Yeah let me know and then we’ll go from there.

I did check and my aggregate device was on 48k and I was able to replicate the problem. However I was also able to replicate the problem without using the aggregate, so just to take variables away I went ahead to did that.

The digital distortion prints into the audio so I was able to track it. This kick + snare are from the GoldBaby S2400 factory expansion just to confirm that I’m not using weird file formats or something from my SD card.

And then here is my Ableton setup (really doubt MIDI would have anything to do with it but I attached). Again, just using the 2400 on its own as the input, not aggregate. Although I do get the same problem on aggregate. My CPU meter hasn’t gone above 5% + I have no other applications running. Please let me know if I can get you anything else to help!

Screen Shot 2021-09-15 at 10.25.17 AM
Screen Shot 2021-09-15 at 10.25.10 AM

What happens if you take the UAD out of the chain and make the S2400 the output and send the audio out the headphones or L/R mix outs? I’m suspecting that may be where the issue is…

Also I know you said you tried different buffer rates but do increase your buffer up to 256. I can’t run it that low with devices synced. There may be some invisible overhead there causing some problems. The other option is to try a different USB cable as well, though it’s not likely the problem but easy enough to rule out.

1 Like

Hey @tom I’ve got a pretty similar setup to you (Apollo x8p, iMac Pro) I find 128 samples is a bit too small for both devices. I know you said that you have bumped it up to 256 and 512 with similar results. Is this on an empty project or some existing project that is on the largeish side?

1 Like

@iofflight @StupidAmericanPig

Thank you both for getting back to me. I’ll be home later tonight and will try to confirm that the problem occurs when I remove the Apollo— I believe that it does. + if it was an output problem, wouldn’t it not print into Ableton? Regardless, good thought.

Also I’m happy to up the buffer + recreate the problem again but my computer is pretty souped up and able to run most large sessions at 128 or 64. I really don’t think this is a buffer problem. This audio recording was from a session with fewer than 5 tracks, basically fresh. Also had just turned the 2400 on and switched to it as the audio input.

Thanks a million guys.

Anytime. We really are just going through the steps once again. It is most likely some configuration that is making things unhappy with USB in, we want to rule out everything possible including the USB cable.

Are you on Catalina by chance? There are known issues with USB Audio and that OS. I’m on 10.13 and 10.14 on my Mac Pro (different HDs) and Mojave on my macbook pro. There have also been issues with later Macs - 2019 on with USB Audio.

Got it- I can definitely try another USB cable as well. Going into a hub too so can bypass that.

10.14.6 Mojave is the operating system from the morning, the last one before Catalina. I did however also replicate this on a much cheaper Mac Mini I have running an older OS. I think Sierra

1 Like

Yeah that OS shouldn’t be giving you issues. But I’ll boot my Mac pro into that version (I’m mostly on the 10.13 due some outdated interfaces no longer being supported) but I can give it a go on that one and see what happens.

Is it happening no matter what file type of sample you are using?

What do you mean by type of sample?

I do get the output error if I’m using something loaded off the SD card or sampled in. But to make things easy, I wanted to demo with some of the stuff that Isla provided, ie. The GoldBaby S2400 pack

I meant format - Wav, AIFF, and is it 32 float or 24 bit etc.

Ah right on. I have something like 40 gigs of samples on my SD of various stuff but it has happened regardless of the sample. 95% of what I’m using is .wav 24 or 16 bit. Next time I can get the error to replicate I’ll try to use various file formats.

I used the same GoldBaby samples in the same Ableton session with a restart of the comp and haven’t had the problem again tonight. Again, this problem seems intermittent and I have yet to find a pattern of what exactly triggers it.

Yeah it was a reach that it was related to that… I was just taking you through my own trouble shooting process when I can’t find the a more obvious source. If we remove the peripherals (files/SD and cables) as the potential issue then it means there is really only the computer or the s2400 left. And because it happens on more than one computer the issue is likely something with the S2400 and the way it’s interfacing.

I guess I’m now wondering how you’ve got your USB connected. Is the S2400 connected directly into the computer, does the computer have other USB buses being used or are you running it into a hub? I’m really just reaching for other possibilities at this point.

Hi Tom. I know @iofflight and @StupidAmericanPig are already on the case, and I won’t add a third layer of support otherwise it’ll get confusing. But, just to say that I would test without the hub as a priority. Not saying it will necessarily solve your problem, but it’s a fairly big item in between the S2400 and your computer and not all hubs are created equal. Good luck :+1:


I missed that comment about the Hub last night, it was late. I have my 2400 going into a hub but it’s high speed and powered externally. I think that is key. It actually works better than my mac pro 2.0 ports most of the time.

1 Like

@rozz3r @iofflight

Oh I have been burned by a cheap hub MANY times before. This one is external powered USB 3.0 but another good idea! Will go direct for the rest of this to remove another variable!

1 Like

Did you try connecting it primarily yet?

1 Like