Another bug with resampling

Got another bug with resampling.

The context is as follows. Created 8 mutislices on pad B1->P8. I want to create the 12 bit version of theses samples on pad C1->C8. But doing the resampling process seems to create nothing with 0.000s as information. I can’t find corresponding samples in “Browse Files”. I can send the project in private if necessary.

Seems to be an issue when using the same sample on 2 tracks. I’ve tried to rename before or save before but without success.




I just tried the steps you listed but couldnt duplicate it. I may have done something differently than you.
I was in a new project(unsaved at the time). I assigned a sample to A1 and to A5. Then I went to A5 and through the Assign Sample menu I resampled the sound on pads A1 and A5, saving both the project and the resampled file at the same time, and saving the file to the project(not same folder). Did you already have the PUSH project saved when you resampled?

1 Like

Thanks for trying. This one is very difficult to reproduce I think.

I started this PUSH beat 2 weeks ago so it was already saved. I started it before the OS update. The bug above is after the update. (it is not a before/after thing I suppose).

I tried everything that came to my mind. Resampling after assign, resampling in the file browser, saving after or before, renaming myself or not without success.

Next weekend I ll try to recreate the bug in a separate folder. Hopefully I can recreate a reproducible step by step procedure.

1 Like

Are you trying to resample slices from multi-slice mode, or have the same sample on pads B1 - B8 and want the 12-bit versions on C1 - C8?

If it’s multi-slice you’ll need to save each slice as it’s own sounds file first. Can’t resample a multi-slice as it sits, as it’s just a snippet (start-stop point parameters) of the sample you have assigned to the pad - until saved as its own file. What it sounds like you’re going for, you’ll have to either:

  1. Resample the original file, assign to C1. Then in multi-slice C1 - C8 will be your 12-bit slices
  2. save each slice as it’s own sample, resample those and assign to pads C1 - C8

Can definitely have the same sample on as many tracks as you’d like so don’t think that’s causing anything. Going on a limb and assuming it’s the multi-slices you’re trying to resample.

Thanks for your answer.

To sum up the whole process which is spread in severals topics:

I have a 40 second sample on A4 which is 16 bit. I did level and multislices adjustment for this long sample. I have 8 slices. They are at the transients and random. It is not like it is equally divided.

The ideal worklow would be copy this track and then resample it to 12 bit and then OK.
Unfortunately it is not as simple as this. First workflow killer issue is when assigning a new sample track settings revert to defaults. Which is the case if I resample to 12 bits. Level and Slices are lost. Other small issue is when resampling to 12 bit with 33@45 the 40 second sample doesn’t have the same sample length anymore. The Slices start and end points can’t be at the same place.

Two things already requested to overcome this. Unlinking assign and track parameters. This would mean no parameters reverted automatically to default. Nothing lost automatically. And for resample a new window with extra options. The ability to pitch it down immediately after pitching up.

Anyway to try to overcome these limitations, I tried to create multislices then copy these multislices. So to answer your question I create everything on A4, then exctracted slices manually and assigned samples to B1-B8. After adjustment on B1-B8, put these slices on C1-C8 to create the equivalent 12 bit version but could not resample at this point. It created nothing or something empty I don’t know.

I will try to recreate a reproducible step by step if there is a bug somewhere :slight_smile: