A Few MIDI Features Not Working For Me [RESOLVED]

  1. MIDI focus is not working. No signal transmitted when A is engaged. Tried all midi options and all midi channels.

2 & 3 Pitchbend and Mod wheel messages are not being indicated nor passed through to external devices

  1. Not able to duplicate that. Can you upload your midi track map file?
  2. Pitch bend is not supported, as stated in the MIDI implementation document.
  3. Mod wheel is supported. It is just CC 1.

Couldn’t upload directly from my iPad for some reason

I tried with an Arturia Keystep and from a midi controller app on iPad

Okay. Looks like you have not changed the defaults. That’s fine.
What do your Sync settings look like? What port is the keyboard/controller you are using connected to, and what MIDI channel is it sending on? Do you have that port and channel set as the control port/channel?

With the Keystep I tried using USB H in the ‘Control Settings’. I also connected a midi cable and set it to Din

After that I set it to USB B and connected my iPad to the B port

Each channel triggers with A button un-engaged and records to the chosen channel outputted from the controller. When the A button is indeed engaged there is no response on the pad led nor the connected instruments

Ok Control Channel was set to 16. Setting to 1 go me responding properly.

Im still not getting a response from modulation Messages

The CC1 messages shows in the ‘Midi Monitor’ section of my unit. It works properly when I connect the Keystep directly to the synth. So are there any midi filters in the S2400 that i may have altered accidentally?

There are no MIDI filters. Except that the only messages that are recorded are those that you configure. Since you did not configure any controls on any MIDI tracks for CC1, it has no effect. I can see in your map, that you have all defaults (CC 7, 71, and 74).

I didn’t realise pitch bend via MIDI wasn’t supported.

Is this expected to be added? IMHO this is essential if the S2400 is being used as a central midi sequencer


The problem is that the S2400 step sequencer isn’t designed to record streams of MIDI Data like a piano roll does.
Think of the MIDI tracks more like a MIDI version of the Sample tracks. Just like Sample tracks, note parameters (ie. fader positions, MIDI CCs) are only recorded at note-on (and if you don’t have a CC assigned to a fader or knob, it’s ignored). You can’t do mod-wheel wiggling or pitch-bends just like you can’t record filter automation after a note-on in Sample tracks. That’s the way it works right now. Only Mickey and the angels know if that can ever change :smiley:


Hopefully pitch bend can be implemented at some point despite the above.

Using the S2400 as a central midi sequencer with a master keyboard to play other devices in the studio using MIDI focus and not being able to bend the pitch on those devices (either during live play or when recording a MIDI sequence) is a big limitation

1 Like

I just hooked-up my Akai S612. It has the MIDI CC modification (by Hideaway Studios) for controlling the start/end sample loop points with MIDI CC’s. I was wondering why the S2400 wasn’t recording my continuous midi CC tweaking. It only works at note on.
Damn shame.
Is this something that has the possibility of being added in the future, do we know?

1 Like


If (temporarily) using an Electrix FF in the S2400’s midi In, let’s say to control/midi-record itself by also having the Electrix FF on the S2400’s midi Out… does that work?

In other words, can you control/midi-record the sweeps, playing, etc. from an Electrix FF on the S2400?

why if i tap a step in midi mode in step sequencer is there a long line in OLED that goes to the pattern end and sends a full sustained note out that does not stop until pattern restarts? this is in pitched mode.

no note off is sent - click the note in the sequencer page with the encoder and the note length is a negative, there is no way to make it positive…has nobody seen this? i cannot believe in good faith this made it through testing and was not seen as a bug so therefore i have to think it is me but i cannot fathom it for the life or me…

any help appreciiated - very simple, goto midi mode, hit f2 for TR mode, add step and look at oled, now press play and full sustain is sent

The missing note off for gated notes in Step Program mode is a bug. It is fixed in dev.


@Mickey any plans on supporting CCs without note messages?