USB/ ASIO4ALL connection issue

Greetings all,
Hi. I’m having issues with the s2400 USB connection to any of my DAW’s. I’m using a DELL Latitude E6520, Intel Core i7-2640 M CPU @ 2.80 GHz processor, Windows 8.1 Pro, 64bit, 8.00 GB. I’ve downloaded and reinstalled ASIO4ALL version 2.14 – English. I’m using Avid Pro Tools 12 Software, Steinberg Cubase 10.5 and Sound Forge 14 to record music production. At first my laptop would recognize USB connection and could drag audio to the sd card, but couldn’t plug and play. Now there’s no recognition whatsoever. I’ve used my wife’s laptop (Windows 10 ) and instantly it recognized the s2400 as a plug and play USB. Is there anything that could help solve these issues so I can use USB audio mode to track out?

Uninstall the latest Asio4all and download a previous version from a few years ago. I know this has worked for a few people.

1 Like

Ok, thanks. Would you happen to know the exact installation from the site?

This problem goes way back to 2012. I think your okay to choose any old version.

1 Like

The older version of ASIO4ALL 2.10 didn’t work.

Brad is it possible to give me a driver exe. installer for the s2400? For some reason Windows Pro 8.1 doesn’t want to recognize plug and play USB or ASIO4LL / USB. I can use USB to drag sounds to sd card but can’t to track out 8 individual sounds.

Problem solved by upgrading my Windows to version 10. The issue has something to do with Windows 8.1 Pro. I had to bite the bullet by having to reinstall all of my DAW’s, plugins, etc but it’s worth the gain in my opinion.

1 Like