Round-Robin issues?

OK so I’ve got a simple drum loop that I put on [Pad 1] and set to [Round-Robin Mode], I can get it doing the round-robin effect without the sequencer running, but then when I hit record it just plays the first slice over and over while recording. Then when the recording sequence loops, it plays back as it should have while recording.

Am I doing this right or is this a bug?

It also seems to happen when I enter [Loop Slice] mode on another track. In this instance I’m trying to add a kick, truncated from a loop:

“While recording, the actual slice is heard and recorded. When the pattern comes around again and plays that event, it will be round-robined.”
– The User Manual


Thanks Mikey, I missed that part apparently.

I love the round-robin function so far- it’s super cool- but this seems like a bit of a burden in the creative process, no?

It makes it difficult to know or play the exact timing (as seen in the video) of the part I want to lay down in round-robin. Instead I just have to anticipate the end result and hope that it happens as the first note in the round robin has different tonality and shape than the other hits.

All due respect, just sharing my opinion and being picky. It’s still a fantastic addition :slight_smile:

You can use quantization and the repeat function. Set the quantization (in which you would like to trigger the single notes) quickly by pressing and holding the Quantize button and rotating the Select Knob. Then you can press and hold Tap/Repeat + press and hold the Pad → it cycles through

1 Like

I’m really into the new Round Robin feature. It’s a great addition for experimental users. The only issue I’ve found is playback can be quite ‘clicky’ (like when your sample start and end points are not properly zeroed in). It could because I’m using unusual samples (eg not standard rhythms / percussion loops). I’ve been experimenting with quite abstract loops, very textural and melodic stuff. Adjusting the envelopes and filters doesn’t seem to help soften the clicking. Hope this is something that can be refined in an update.

1 Like

I think you’d be better off making sure your material is fit for purpose - prepare your samples to make sure everything is snapped tightly to 8th notes on the grid and you’ll have a great time

1 Like

It is, I’d just like to be able to hear it as I enter it into patterns, ya know?

I’m trying not to be picky but this feature addition feels like it’s a bit unfinished. Just being honest.

The round robin video has a random a and a random b mode. But both in the manual and also in the sapler this options are not available (only random). Am i missing something?

It is working exactly as designed and documented. That topic was discussed before release. We may change it or refine it in the future, but the feature is finished.

1 Like

@Gattosuper that video was made with a beta version before RandomA, RandomB and RandomC were renamed shuffle, Brownian and random.

But that 2nd video in this thread… Isn’t that a bug?

Yes, that is a bug. It does not round-robin when the waveform editor is displayed (intentionally). But, that should only affect the track being edited.

1 Like

OK, thank you for the clarity Mickey :relieved::pray: