OS freezing [FIXED]

After assigning a sound to a pad in a project the unit stops responding. Unit has to be power cycled to work again. If I try again to assign that sound before opening a project, it works fine but if I open ANY project, the unit locks up after assigning the sound. I can reproduce it.

It’s happening to sounds from a specific library on the SD card, other libraries are loading fine. And the problematic sounds load fine if I’m not in a project.

I can make a video if needed

1 Like

what specific sound is it?

vocal-2.wav from Zero G Datafile 2;

In fact, all the wav files I tried from that folder are producing the same error, and it happens after the sound is assigned and the pad hit. If the pad isn’t hit, it continues to work until the pad is hit and then it freezes.

If I resample it before hitting the pad, it works. This is my workaround for now.

well, since this is not one of the preloaded factory sound, just telling me the name won’t help much :slight_smile:

I’m sorry if I wasn’t clear. This issue is limited to a sample set contained within a single folder (so far) and it happens to be one from my personal library. I can give you whatever details you need, I want to help get this annoying bug fixed. I’ve lost count how many times I’ve had to force restart my S2400 in the last week and it isn’t fun.

What more info do you need?

I can tell you they were converted to 48KhZ in dbpoweramp, as were my other samples which (so far) load fine. I don’t know why samples from this folder are locking up the machine and others aren’t. It’s very odd.

Edit - it happens on pads D3 & D4, haven’t tried any others

The unconverted vocal-2.wav file does not crash my machine.
(from either of the zero g disks)

Please upload your converted version here so that we can test it.

1 Like

Sorry I made a mistake it’s vocal 2.wav from Datafile 1, not Datafile 2!

Sure, will upload file when I get home, thanks

here’s one of the offending files

Were you able to reproduce with the uploaded wav?

Your wav does indeed crash the machine here too. The good news is that it’s fixed, the latest in-house beta plays it fine.

Just as a side note, the file is 32bit float. Although the S2400 does (now) support 32bit float files, there’s really no need to use this format. 16bit is fine, as is 24bit. 32bit will just use up extra RAM and SD card space, for no gain.

1 Like

thanks for that, and the side note - I didn’t realise I’d made a 32bit float file. I converted a batch of samples in one go in dbpoweramp, I’ll need to find out how to avoid that in future

if you batch convert, convert to 48Khz, 16 bit