MIDI issues - recording [FIXED]

I have a Midi recording issue I just can’t seem to resolve. I have tried many configurations and will list a couple to see if someone recognises something obvious I may have setup incorrectly. Scenario 1: Prophet XL inputting midi to s2400 via USB Host port, In from USB host checked under MIDI ports. Output to Ensoniq ESQ-1 via Midi DIN (Out to Din checked). ESQ-1 plays fine as is, timing perfect in real time jamming etc as long as I don’t enable record.
The issue begins when I record the midi data. As I’m recording, midi notes start to hang, almost sounds as if there is Midi feedback etc, although I can’t figure out why. When I’ve finished recording, turn off the record button and play it back, it sounds like it should. Under SYNC settings menu I have left everything unchecked, but have at times also experimented with different settings here to no avail.
Quantise setting - default, and have also tried Fine, makes no difference.
Scenario 2: Similar to above but using a different controller (Virus Ti2 Polar) inputting midi data to S2400 via Midi DIN to control the previously mentioned ESQ-1 via Midi. Can only get this setup to work when selecting ‘Echo’ under ‘control settings’. Has the same note hang, midi feedback type behaviour as before though when recording.
Latest firmware installed.
I haven’t noticed anyone making comments on anything like this, so it’s obviously just me overlooking a setting or perhaps people are not recording midi data in realtime much?
For now I’ve reverted back to my Squarp pyramid for midi duties, which works flawlessly, but would love to be able to record midi stuff on the Isla s2400 without a hitch sometime in the future to keep my recording centralised to the one machine.
Any assistance or suggestions would be greatly appreciated.


What’s happening with your clocks? Are they being sent out? Or are you filtering them?
The Dave Smith and modern Sequential have a lot of curious settings for this sort of thing. Ultimately, I imagine, you want the midi notes to be recorded into the S2400 and that’s all, yes?
I would turn all clocks, cc, and other stuff off (set to internal, turn off, not sure exactly what language Dave uses these days) but I’ve had a lot of hassle with DSI stuff when trying to use them as controllers. Never as the recipient of midi, or stand alone use. But the sending of errata and extra things has caused me a lot of hassle too.

I can’t tell you exactly, I’m sorry, but I would go through the manual carefully and take a look at all of the midi options and switch them all off until you’re just sending note data to the S2400 and see if that doesn’t make things a lot easier.

For the Virus, I’ve had an A, B, and a Ti. I never loved the midi implementation, and didn’t find them friendly controllers. But as with the Prophet, I would go into the settings and shut all the CC and clock stuff down. That should help a lot.

I love my Pyramid too. It’s a great controller, but I often want to use more of the keyboard at once, so I totally understand your struggle.

Do us all a favor, and please report back what works and what doesn’t work?

1 Like

Here’s the setup I’d suggest for getting MIDI to work nicely:

  • update to 2021-10-09 Update (or later) - there’s a couple of MIDI fixes here that might help
  • With your Prophet X as controller, go to Sync / Control Settings and setup the port (USB H) and channel. Echo is fine ON.
  • With this setup, you DON’T need to enable Notes, Velocity or CC In under the Sync / USB Host Jack menu unless you want to control Audio Tracks with the Prophet.
  • On your MIDI Track, you also DON’T need to enable In From USB Host in the Track Settings / MIDI Ports menu.
  • You DO need to set the output Port and Channel to match your ESQ-1.
  • Now, when you’re ready to play/record, press the A button on your MIDI Track. This will enable ‘MIDI Focus’ and allow you to play and record to that Track for as long as the A button is lit. This will work for any MIDI Track(s).

tl:dr - the Control Settings menu in Sync allows you to set up your master controller keyboard which can be used with any MIDI track with ‘MIDI focus’.

Let us know how you get on :+1:


Thank you to those that have responded so far, I appreciate you taking the time and for having some suggestions that I didn’t think of. Firstly, regarding clocks, cc etc, midi monitor on the Isla 2400 is only registering note on and off messages from the prophet and virus, nothing else. To clarify, yes, I am just trying to record straight keyboard parts (midi notes only) into the isla 2400 and play them back once recorded as I play them in with no quantisation. To be sure though, I turned off all of those settings on the prophet to try again, but it didn’t make any difference. Same with virus. Re rozz3r’s suggestions, I hadn’t tried the Midi focus option and hadn’t previously tried ‘not enabling’ the incoming midi port on the MIDI track under Track settings / midi port menu. I was excited to try these options, however, the exact same outcome continues to happen. When recording the midi data what I am hearing is a hanging note or two, as if the machine is receiving a feedback of midi information somewhere. As soon as I turn off the record button and the sequence plays over, it sounds as it should without the hanging notes. I also tried turning the record button off and leaving the A button (midi focus) on as the sequence played back and that was also producing the strange hanging note behaviour. Any other suggestions?

Is there a ‘local off’ setting on either of the synths? Such a setting disconnects the keys from the synth engine and only sends out the midi. The midi will then be coming from the s2400 only. Hopefully, then s2400 will be sending back the midi while recording…

I’m getting the same issue. I have a MIDI keyboard connected to the DIN MIDI In and a synth connected to the DIN MIDI out. The s2400 relays notes perfectly if I’m not recording but recorded notes hang all over the place. I am running the latest firmware. The first video below shows settings and the second vid illustrates the problem I’m having with recording. I only show a 1 bar loop but longer loops are equally problematic. As are other input and output devices. I’ve not tried USB.

1 Like

@rob Thanks for the report and videos. Any chance you could upload your Project and S2400.SET file from the root of your SD card. Then we can try and reproduce the problem with all your exact settings.

Btw… that SE Code :heart:

1 Like

Well done for posting vids, that was my next step when time permitted. Your videos show exactly the behaviour I was also experiencing when trying to record the midi data. In response to a previous poster regarding Local on/off, this makes not difference in this scenario. Glad to hear I’m not the only one with issues trying to get polyphonic midi parts to play back properly. Any chance anyone from Isla could post a vid playing some chords in via midi demonstrating that it works correctly and share the settings? I’ve watched the Alex Ball vid on midi sequencing a few times, but I guess he was also using an older firmware. Not sure if that makes a difference or not.

1 Like

Same here and I have tried everything. I want two synths to sent midi notes to record sequences into the s2400 and then back to the synths to play them back. The only configuration that have worked for me is Prophet 6 on Ch1 hooked by midi host in and out. Grandmother on Ch2 hooked by midi din in and out but I also get the hanging notes from time to time, they keep playing even though I stop playing the S2400.

When recording MIDI from my synths the S2400 won’t record note offs properly, effectively making some of the notes play legato.
This is happening either using DIN or Host connection.


I’ve had problems with already recorded notes being cut of when exiting record mode, but I think that is fixed in the next firmware already.

1 Like

Having the same issues, here- tried using the S2400 as the master sequencer, controlled by my SQ-80 (DIN-MIDI). Getting notes hanging and weird legato once the MIDI has been recorded.

I can try to upload a video in the next day or two if the devs need some backup.

Love this box to pieces, otherwise. Really great machine, and the sound is superb!

I set things up as recommended in this thread but I also have this issue with hanging notes when playing back midi from VST synths in Ableton after recording. At the moment it is unusable for me. Hopefully it is fixed in a firmware update, I will experiment with a hardware synth to see if the behaviour is different. Hopefully it is something in the DAW

I have my 2400 hooked up to an E-MU module. Notes hang or get cut short after I hit stop recording.

I believe this falls within the Gate issue that has since been fixed and is in the new firmware set to be released soon.

I have the same issue with my Typhon connected either via the USB host or DIN.
If I use the S2400’s pads to trigger notes on the Typhon, they’ll hang. If I make the Typhon trigger it’s own notes, the note hang goes away and it works as expected. Also, a MIDI panic clears the hang, which is expected.
I’ve fiddled with the various settings on both the Typhon and S2400 and haven’t found a combination that alleviates the hang.

1 Like

Didn’t get fixed with the 2021-11-22 Update.

1 Like

Project and S2400.SET file featuring dropped and hung notes when sequencing chords:

1 Like

Same issue for me, chord notes hang.

I bought midihub hopping that I will be able to reduce the midi feedback but looks that you are having problem with midihub as well. I’m currently waiting for the midihub to arrive. Does it get better with the midihub?

Latest firmware and I’m experiencing the MIDI note hanging and ghost notes during recording when using the S2400 as sequencer