Live loops dissapearing from saved projects

Is it just me or are live loops disappearing for you guys to?

I can’t say how and when it happens but every now and then when I open an old project where I know there were saved live loops, the loops aren’t there. The A buttons are lit indicating there should be a live loop there but the screen says live loop empty.

Seem to happen when you do a save as sometimes to.

Very strange and sad to loose a lot of good takes…

I’ve reported this several times before. It came down to a semantics discussion with Mickey which I lost. I am used to ‘save as’ Ableton style where everything within the project is saved in a new directory. Mickey wants only incremental saves…

The good news is that your loops in your projects are probably not lost. If you have used save as, but have kept all previous projects, then it is recoverable.

On your computer copy all loops from the older version into the map of the most recent one. Then load the project in your s24 and it probably works out.

It happens with projects that is not a ”saved as” project to unfortunately. Maybe the loops are still there in the folder, haven’t checked on a computer yet. If the files are still there I quess it must be a bug if the project doesn’t load them correctly?

Now something very strange happened:
A project I’ve open several times the last couple of days which had lost it’s live loops now suddenly had the live loops back. Definately something fishy going on…

1 Like

Saw another guy in the facebook group having the same problem so I guess it’s not just me.

Could the team comment if they’re aware of this and a fix is being worked on? :slight_smile:

@Mickey

How do you mean the save as works according to mickey?

If you do a save as everything but the live loops gets copied to the new folder?

The loops dissapear from projects where a save as has not been performed to so I’m not sure that’s the problem.

Some projects I’ve been opening lots of times without problems and then like a month later it won’t load the loops all of a sudden.

Here I am.

Unfortunately for me most of the projects with live loops are empty. No files even in the project folder, still the liveloop banks shows like they are filled.

sometimes I do find the recorded loops in the project folder but they can’t anyway be reloaded in the loop. And even if they could , it does mess up with the whole song building as it was saved.

@syah71 I don’t recall that conversation. The SaveAs issue is definitely a bug. And an easy one to reproduce. I just fixed it.

1 Like

As for sometimes not saving or not loading live loops, I have not seen that happen myself.
It would be great to have steps to reproduce the issue.
It is surely not random. There is some particular condition that makes them not load. But what? Does it happen on a clean boot? or only when another project has been loaded first? or only just after saving? Etc.
Any additional detail will help fix it.

I haven’t been able to figure out the cause but I will really try to see if there’s a pattern to when it happens.

Like I said above last week I opened an old project where I’m sure there were some live loops and they were not there. I tried reloading the project multiple times and did switch of the unit in between. Then the next day the live loops were back but now they are gone again when loading the project.

The A buttons were always lit but if you pressed a pad the screen said it was empty.

It must be related to what you did just prior to opening the project.

This is the thread:

https://forum.islainstruments.com/t/save-as-includes-everything-from-current-project/2957/1

When I read it again, I must admit that you never talked about incremental saving. But this was my own conclusion when you did not want to talk about save-as (memory content) to a new SD card. To me that triggers a train of thoughts of a saving system that keeps track of things that have been saved already (great for better performance), hence the term ‘incremental saving’. But I might be wrong.

@Mickey Can you explain why a save-as to another SD card is not possible? I know that longer samples are not in memory, so they are lost.

Live loops are entirely in memory, they don’t ever stream off of the SD card.
Short (<2M) samples can be in memory, but are not guaranteed to be. They may not be fully buffered at any given time. We can force them to fully buffer, but that requires the source SD card still be inserted. If you pop it out, stick a different one in, then press save, memory could be in any old state.

1 Like

Still can’t figure out why this happens unfortunately. Maybe there can be an option in the live loops config menu that let’s you reload the live loops when this happens if there‘s no other way to figure out how to fix this bug?

Since the loops seem to still be in the project folder just that the machine doesn’t load them correctly…

@Melkerpetterson Pressing F4 twice to turn the live loops off then back on should reload them.
Please let me know if that works or not. It would be useful info to know that.

1 Like

Oh great! Didn’t think of that. Will try next time it happens.

1 Like

Any update on this anyone ?