Live-loop gets cleared when saving sample to pad

I’m not sure but I don’t think this was the case before the last update, but I could be totally wrong.

Is it intentional that a live-loop is erased from the looper track when the loop is saved to a pad?

If so, would be great if there was an option to not erase it from the looper and instead just automatically muting the looper track. Sometimes you just wanna save a loop to a pad and chop it but still leave the loop in the looper.