Live looper bug, cutting last bars when pressing A

I had this happen in a jam session with a friend the other day and now it happened again so I thought I’d make a video and post here.

So I have a 4 bar pattern and when recording a live loop over that it plays back the 4 bar loop as long as the loop is still in the record buffer (B button lit), but when committing the loop (pressing A-button) it only plays the first two bars, cutting of the last 2.

This doesn’t happen regularly and I suspect it could have something to do with me having started out with a 2 bar pattern and recorded one live loop over the two bars. Then I duplicated the pattern. The first live loop now only plays during bar 1&2 out of 4, this is another bug I made another post about. So to work around that bug I saved the loop as a sample and played it from a sample track triggered on first beat of bar 1&3 so it plays the loop over the whole 4 bar pattern.

But now everytime I record a live loop the last 2 bars gets cut of when committing the record buffer (pressing A-button).

Here’s a video

Tried restarting the machine and loading the same project again and now it works as expected.

1 Like

I could reproduce the bug multiple times. Here are the steps:

  1. Start the machine, record a pattern (Length=1)
  2. Switch to Looper by pressing Shift+F4
  3. Go to Pattern Length and duplicate the pattern
  4. Record a loop (now Length=2)
  5. Press A
  6. As a result, the loop is truncated to Length=1, the second part of the loop is silent.

It seems that loops are always truncated to the pattern length which was set before activating the looper bank.



Also you can’t duplicate the pattern after a loop is recorded, the loop will only play during the initial pattern length and be silent for the other half.