Live loop will only merge recording (A) to the first half of loop after patten length is duplicated [FIXED]

If you have a live loop recorded and then duplicate the pattern length (Patten Length/Duplicate Pattern) then it is no longer possible to merge new recordings into the second half of the live loop. You can hear the recording for both halvess of the loop when it is recorded and played from the recording buffer. But when you merge the recording buffer (A) only the first half of the loop is merged.

Also, it would be nice if also the live loops would be duplicated when duplicating the pattern length (Patten Length/Duplicate Pattern).


Yes, I posted about this a long time ago now. Hoping it will be fixed soon!

The live looper is pretty much unusable currently if you set pattern length to anything other than 1 measure. You get all kinds of weird behaviour when recording. Such as hearing what had been previously recorded in the recording buffer (recorded on another track) when engaging recording on a new track. And as mentioned in my original post, merging the recording buffer yields all kinds of strange results.

It seems like the behaviour also is dependent on whether the pattern contains any sequencer events for any of the sample tracks. Might be related to the issue that the pattern length wont be saved properly if the pattern doesn’t contain any sample track events.

Anyways, using the live looper as it is is currently very frustrating. It certainly needs some work. I hope we will see improvements in this area.


Found a workaround to get live looping working in a new project (and pattern) with a pattern length greater than 1.

  1. Create new project
  2. Add a sample/sequencer event to any sample track (otherwise pattern length wont be saved correctly for the pattern)
  3. Extend pattern length to the desired length
  4. Enable live looping (Hold F4)

This seems to initialise the live looper buffers and recording buffers correctly.

I am now even able to for example first create a pattern with 2 measures and after that another pattern with 4 measures. And live loop recording seems to work fine. However this makes me realise that it would probably be better if the live loopers pattern length would be set globally per project instead if being tied to the current patterns length. This would make more sense i think, since the live loop recordings are global for the whole project. Otherwise the pattern with length 2 will just play the first half of what is recorded in the live looper buffers. And i really cant really see where this is the behaviour that you normally would want.

After some more explorations i have realised that the workaround mentioned above really doesn’t work. I got back into the state where merging the recording buffer only seems to merge the first measure.

And after merging, when reengaging recording on the same track the recording buffer data previously recorded for the second measure is still there in the recording buffer.

This is super confusing and clearly doesn’t work properly.

1 Like

I have also experienced some odd behaviour with live looping. I haven’t made a post yet because i’m still trying to wrap my head around what exactly is happening. But, basically, hitting button A to commit a live loop works perfectly sometimes and not at all others. Sometimes I hit A and it seems to cut my live loop short… at the moment I hit A. It keeps looping around and cutting in and out. Then if I erase that whole track and go to start recording that part again… the part I previously recorded that was cut off is now abck in full but won’t let me commit it with the A button. So, yeah… not ready for stage yet. but I’m having a lot of fun with the live looping and see a lot of potential for that feature. Fingers crossed it gets smoothed out soon.


The live looper is one of my favorite parts of this machine, and the only way you can actually record something live with the pattern running. But these issues is a real problem. I’ve had some embarrassing moments in sessions when it totally kills the flow.


Yeah, I I feel you! Ever since I discovered that issue I reported (Live loop recording adds unwanted signal - #10 by cfd2), I haven’t turned on the unit because it really killed the workflow for me.

@Petur This problem where the second half of the buffer isn’t written to the live loop when you press A. We’re unable to recreate the problem so far. Can you run through the exact steps you’re taking to see the issue? Or even better if you have a saved project that exhibits the problem, upload it. Thanks.

Here are some simple steps to reproduce the issue.

1 Create a new project.
2 Turn input monitoring on for the source you are going to record your loop from.
3 Enter a sequencer event in any of the sample tracks (otherwise the pattern length wont get saved with the project).
4 Enable Live looping (Hold F4) and switch to the looper bank.
5 Record a loop into looper track D1 (Pad D1).
6 Merge the recorded take (A).
7 Change pattern length to 2 measures.
8 Overdub something on looper track D1 (Pad D1).

At this point you can hear the full 2 measure loop being played back (played back from the recording buffer).

9 Merge the recorded take to track D1 (A)

Here you will notice that only the first measure has been merged to track D1 (second measure is silent)

And also, now if you engage recording again (pad D1) you will hear that measure 2 from the previous recording is still there in the recording buffer. This is actually the case regardless of which looper track you now engage recording on. Measure 2 from the initial 2 measure recording remains in the recording buffer.

1 Like

@petur Thanks. I just wanted to be 100% sure. This is already fixed in house, and the fix will be in the next update :+1: